Honda D Series Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter #1
Just did a fresh build on my d16z6 which is boosted. I got a toga oil pump and clevite bearings along with all forged parts and cams/springs/retainers.

Now when i start the car the oil pressure light comes on and then goes off. Could this be from running 15w40 to break the rings in? And does the oil pressure light come on for high oil pressure?

Also the car smokes after it gets a little warmed up. I am wondering if this could be my turbo since i have a -4an line on it without any restrictors or is it is something else i should check.
 

·
Registered
Del sol
Joined
·
800 Posts
The light comes on with low oil pressure. When you say it comes on and off, do you mean its blinking? Does it come on with low rpms? Put the car in gear and pull the hand brake, slowly let go of the clutch so the rpms go down, and see if the oil light comes on or blinks. Also an oil pressure gauge is a pretty important investment on a turbo build.

remove the downpipe and check for oil for the turbo.
 

·
Premium Member
The Wife and the Car
Joined
·
2,053 Posts
Did you prime the pump after your re-build.
Did you check to see if you are getting oil up to the head. If not you have probally been runing with no oil and taken out the rings / pistons / bearings.
The honda pump like most car pumps does not have the ability to suck up oil from the sump. After a rebuild you must either prime the pump or fill it with grease / P jelly.

Dont ask how I know LOL. We nearly blew and engine like this but switched off the engine as soon as we saw the oil light. So it only ran for like 5-6 seconds without oil No damage cause we oiled up all the parts with extra oil during assembly.

First few starts will have smoke thanks to the extra oil every where.
Do you have a restictor on your turbo oil feed you need one or the extra oil can blow your turbo bearings and result in smoke.
Hope its something simple. And the engine is safe.
 

·
Registered
Joined
·
130 Posts
Discussion Starter #4
It comes on at random times its weird. It will come on and then if i give it a small rev it goes away for a while. I ordered a Prosport oil pressure gauge yesterday but im going to pick up a sunpro today.

Also i have a plate from ATP turbo that goes on the turbo that has a small hole in it but im not sure if that acts as a restrictor or not
 
1 - 5 of 5 Posts
Top