Honda D Series Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
So we got our friends setup working:

Stock Injectors (we have DSM 450's)
Y7 block, Y7 Head, Y8 Manifold
Greddy turbo kits
Stock ECU (Going neptune ina couple weeks)
Fuel pressure is at 40psi


The engine wont rev past 2500, and if we do, it cuts out completely. And if you floor it, it dies.

Do anyone have any ideas?
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Yea, IACV CEL

That would cause limp mode? Wow.

We did the wiring shit properly, we literally did a Y7 Mani-Y8, did the pinout and shit, and changed from 3 wire - 2 wire.

It still came back with a CEL.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #7
We swapped the IACV's, had 2 of em. Both were "supposedly good"

I think it might be the wiring or something.

For the swap to a 2 wire,

You move the pin from A14 to A12, remove the orange wire,

Then cut the 3 wire clip off, keep the orange wire by itself. Yellow goes to green, blue/black goes to black.

Right?
 

·
I can't read...
Joined
·
10,170 Posts
yea no missing link, but its going to be getting neptune

where can i pick up a missing link from?
ebay's got 'em or you could make your own. homemadeturbo.com i think has a write-up on how to make your own check valves.

Best bet is to not drive the car till it's tuned. you don't wanna fuck shit up before you have your fun!
 

·
Registered
Joined
·
13,322 Posts
Best thing is probably just to wait it out... In the mean time, get those 450's and the resistor box in, and get it prep'd for the dyno. Check all lines, secure all hoses (zip ties even), and maybe look into an upgraded pump.

Good luck!
 
1 - 13 of 13 Posts
Top