Honda D Series Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
451 Posts
Discussion Starter #1
Okay this is weird. My uncle is at the place where they are doing my swap and he says like they have problems using the TPS Sensor from the JDM D15B swap. And they are gonna try to use the old D15B7 one? Can that be done? And isnt that engine supposed to bolt on and just do VTEC?

And another thing. The stupid guy who we got the engine from gave us the ECU. The ECU says P54 which is from a EDU Accord 1.8. That cannot fit with the JDM D15B right?

Damn I confused of what they are doing.

Someone help try to clearify some stuff plz?
 

·
Registered
Joined
·
451 Posts
Discussion Starter #3
What thats crazy. We just checked it over and it looked physically fine. The plug itself and the wires were all in place.

And the P54 ECU my uncle described when I searched comes from a EDU (European) Accord 1.8.

Darn WTF are they doing. Must not know how to do it.

I read and it should just be

1. Take old engine out
2. Put new one in
3. Put ECU and wire VTEC
4. Done.

Argh
 

·
Registered
Joined
·
451 Posts
Discussion Starter #5
Okay its done (for now). The TPS was okay, they just took it out to test it.

Anyways the ECU is madness. Too rich for the car and idles are soo off. Anyways went for a quick drive with my uncle..

Frig the engine is fast and smooth! I LOVE IT!

Anyways now we are gonna return the ECU and get the right one.

Its a 93 Civic DX. So which ECU do I get? P08 (original) or P28?

Here is my engine in my car. Now I commence to learn how to drive and get license!



Anyways its not fully done yet...ECU change and tuneup...Some stuff needs replacing.

The engine is clean too!
 

·
Registered
Joined
·
451 Posts
Discussion Starter #7
Anyways I have another problems that I could use some help on...

Okay this car is automatic. Now when we try to pull the trans to D4 it cannot get down passed R. It's in P right, but it doesn't want to go down to R. Now we have to use the key and put it in that hole above the stick to get it downwards. The same goes for the reverse. It's very hard to get back to P since we have to do the same thing.

Whats wrong you think? I dont think it use to happen like that before.

Could it be the wrong ECU causing it or the tranny wasnt put in properly?
 

·
Registered
Joined
·
430 Posts
the thing with the shifter is probably because the ecu is for a manual tranny and it does not have what it needs to unlock the shifter.

all you have to do is take the console off that is around the shifter and remove the lockout solinoid that locks and unlocks the shifter
 

·
Registered
Joined
·
451 Posts
Discussion Starter #9
"all you have to do is take the console off that is around the shifter and remove the lockout solinoid that locks and unlocks the shifter"

I dont get it...lol. Im a newbie.

Anyways I thought it was the ECU cuz it didnt happen when the old engine was inside. Hopefully once we get the RIGHT one it will not happen. Thanks!
 

·
Registered
Joined
·
451 Posts
Discussion Starter #10
Does anyone know what he is talking bout? How and where do i do it?

"all you have to do is take the console off that is around the shifter and remove the lockout solinoid that locks and unlocks the shifter"

Is that proven to work even if the ECU is manual based?
 
1 - 10 of 10 Posts
Top