Honda D Series Forum banner

1 - 7 of 7 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
So I was rolling when I heard something drop off under the car.
The t-belt start screaming and the temperature gage jumped to the red line..
I turned off the car then went home about an half anhour after..
I dont think it lost coolant, and theres still oil in the engine.

What the hell happenned ??
What do I have to replace now ?
Thank you
 

·
Registered
Joined
·
1,402 Posts
need more information.

sounds like you might have popped a coolant line?
check around under the hood and get back to us.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Well there is no fluid leak ! I dont understand.. and the belt is so noisy. Its whorse when I push on the throttle
 

·
Registered
Joined
·
4,585 Posts
Maybe your water pump siezed up and doesnt want too turn, which could cause whine, and engine temp. Take of drivers side wheel and put 17 mm deepsocket on crank pulley and try too crank over engine by hand and see if you can do it. Also check your heater hose's that go into back of manifold from firewall.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #6
My vote is for water pump shitting the bed. Probably seized up and the sound you heard was it being wrenched apart by the timing belt.
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #7
It defenatly was water pump, i got a new one and the car is running just great.. but the belt whined once. Is it normal or it aint enough tighten
 
1 - 7 of 7 Posts
Top