Honda D Series Forum banner

1 - 12 of 12 Posts
T

·
Guest
Joined
·
0 Posts
Discussion Starter #1
i just got my zc swap up and running. i am running a d16a8 with a pg7 ecu, however, every time i floor the car and take it above 5k rpms the check engine light comes on and stays on. any ideas? the only thing i did notice was that the ecu was throwing ALL KINDS of codes after the check engine light came on, it would blink ten times, then three times and a bunch of other blinks. anyone else have this problem? before the check engine light is on, it just blinks 7 times over and over again.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #5
ok, heres the deal. at idle, before i floor it, there is no check engine light and no ecu codes, however, once i floor it and it goes about 5 or 6k the check engine light stays on and the ecu blinks 7 times over and over again. i have noticed what may be a related problem, everytime im at low rpms (rolling) and floor it, it will choke hard and almost cut off(jerks the whole car) and then take off. any ideas? i was thinking either a bad map sensor or bad TPS.
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #8
what i dont understand is why it only throws a code after 5 or 6k? i checked all the wiring and it was tight?
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #9
ok, i replaced the TPS and the hesitation before it takes off is gone, and the engine runs great, however... the engine light still comes on after 5.5k?? any ideas?
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #10
clean out the throttle body with a bunch of carb cleaner and a tooth brush - might help :)
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #12
Disconect the battery to get the bad codes out of the computer. It,s cheap fast and may work if you have fixed all the problem,s.
 
1 - 12 of 12 Posts
Top