Honda D Series Forum banner

1 - 7 of 7 Posts

·
R2.....Zap Balls
Joined
·
5,186 Posts
Discussion Starter #1
will the the selonoid only open the wastegate with the car at full throttle? I'm trying to trouble shoot the boost fall off issue I'm having. I've made a couple runs with it set at low boost level, but not at full throttle and it doesn't seem like it it's doing it's thing. Is there a way to check the valve without boosting,or
do I have to take it full throttle to check it to make sure it's working? I'm just going over everything I can think of to get it fixed.
 

·
Registered
Joined
·
286 Posts
nope..the selonoid will only open the wastegate when it reach the preset/userset boostlevel. the problem with the boost fall off is in the size of the wastegate and the boost level. if your wastegate is set for 30+psi its going to have a problem working at 6psi.. i have a racegate and a deltagate and my hks evc4 has a problem holding boost with the racegate..with the deltagate it runs just fine..also the boost fall off might be cause by the turbo not being able to hold the boost.. try running it at low boost 4psi Full throttle check for boost fall off..then up the boost 2psi to 6 then 8 then 10 or how evan much your boosting if it fall off short then either 1. your turbo cant make the boost level u want or 2. something is wrong with your ebc..like a safety mode. i know that my evc4 will turn the boost down if i spike over 2psi of the preset boost and wont reset it self untill the boost comes back down to 6psi or so.. what ebc do u have?
 

·
R2.....Zap Balls
Joined
·
5,186 Posts
Discussion Starter #3 (Edited)
I have the greddy profec e-o1, I think the valve may be bad. I tried setting it low (around 2psi) and a starting point of 1 psi to start opening the waste gate and it still boosted 8.5 psi(that's where I let out of it to be safe). Right now I'm only wanting to run 8psi to be on the conservative side.Between trying to set the valve duty cycle and waste gate gain I may have it off somehow. I think the damn thing is smarter than I am.I need to try to set it up through auto mode, I just need to get it to the dyno to do it. There aren't too many places around where I live where I can just go make 3 or 4 full throttle runs.
 

·
Registered
Joined
·
286 Posts
whats the wastegate spring set at? i have a 4-6psi spring in my deltagate and even if i unplug the wastegate it will only boost 4-6psi..the ebc valve only open and close and i'm sure it dont pump air to control the wastegate..sorry if i didnt say that before..
 

·
R2.....Zap Balls
Joined
·
5,186 Posts
Discussion Starter #5
the greddy kit is only "supposed" to boost 5.5psi out of the box, mine with the fac hose boosted 7.5psi. I think that's what everyone else's does too. I think greddy may have rated the boost low in the manual.
 

·
Registered
Joined
·
118 Posts
Even if you set the boost controller to 1psi it will still boost to whatever the wastegate spring is set at, you can never go lower than the spring setting with a boost controller, only higher. My edelbrock kit does weird boost spike/drop off things when I plug the vac line straight to the WG and not through my MBC, very strange.
 

·
R2.....Zap Balls
Joined
·
5,186 Posts
Discussion Starter #7
SpoolinSingleCam said:
Even if you set the boost controller to 1psi it will still boost to whatever the wastegate spring is set at, you can never go lower than the spring setting with a boost controller, only higher. My edelbrock kit does weird boost spike/drop off things when I plug the vac line straight to the WG and not through my MBC, very strange.
good to know, thank you. I just droped it off again today to be tuned for the second time, hopefully he can set the crazy thing up for me
 
1 - 7 of 7 Posts
Top