Honda D Series Forum banner

1 - 13 of 13 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
Dohc Zc (Needs Help)

Ive got a 91 si hatch with a dohc zc; cf clutch, cold air, accel wires, large tube header full 2.25 exhaust, shortshift . The car runs great with the stock pm6 ecu(no codes smooth idle). I want to run the pm7 ecu. I have tried 4 different m/t pm7 ecu's. They all do the same thing. The pm7 ecu throws a code 20(electric load). The idle bounces around 1-2000rpm before finally cooling out. Ive tried a new tps, iac and closing the tb butterfly. Im thinking that there is some wiring trick other than the cam/crank angle sensor. Any Idea's???!!!
 

·
Registered
Joined
·
275 Posts
my pm7 throws a code 20 every now and then i fix it by cleaning the ground for the ecu really good(its the ground on the thermostat housing)anyways then i take out the ecu fuse let it sit over night put the fuse back in and its gone.but if it ran fine with si ecu why change it?
IF IT AINT BROKE DONT FIX IT
 

·
Registered
Joined
·
314 Posts
if it is a true DOHC ZC it should use the PM7 ecu anyways, the PM6 is a ecu for the CRX/CIVIC Si SOHC from 88-91. The difference between the US and JDM is the ecu and cam only, and thats a difference of 22-25HP that will get most peoples attention, so the change is worthwhile, also, jolting the ecu by pulling the fuse many time will damage it, its just like clutching 1000HP all at once, from 0, it will damage something, electric current does the same thing over time.

Id check your wiring harness, for cuts, if is an electric load, that could mean there is a short jumping somewhere, causing a high voltage, hense the load code, id check that first.
 

·
Registered
Joined
·
1,402 Posts
DOHCef8si said:
my pm7 throws a code 20 every now and then i fix it by cleaning the ground for the ecu really good(its the ground on the thermostat housing)
This is how I understand it.
It seems to be caused by insufficient grounding of the electrical.
 

·
Registered
Joined
·
275 Posts
im useing pm7 with no codes what he could do is use pm6 with pm7 program.i have a pm6 and it sucks ass running my zc i put the pm7 back in.has anyone used a pr2 with there zc?is the pr2 an auto ecu or manual i havent seen or read much bout that ecu and im just wondering. the pr2 is a euro zc ecu and im useing a euro rover zc.
 

·
Registered
Joined
·
314 Posts
The EDM and JDM motors are about the exact same, FI and all, except the block stamp. Using an ecu other than the PM7 in my opinion is somewhat of a waste, the PM7 is the best one you can get, which also happens to be OEM for the JDM and EDM ZC's.

I think the PR2 is for the DOHC VTEC Si-R JDM Civics, so i dont think it will work, im trying to remember if the B16A1 was OBD0 or OBD-I and II.
 

·
Registered
ef7 crx
Joined
·
322 Posts
I had a similar problem when my alternator shit it'self, i put an alternator out of a sohc PM6 car and the idle hunted up and down like you described, there was some sort of voltage/resistance disrepency between the two systems. I replaced it with another PM7 one and the problem went away.
 

·
Registered
Joined
·
275 Posts
slowcivic2k said:
The EDM and JDM motors are about the exact same, FI and all, except the block stamp. Using an ecu other than the PM7 in my opinion is somewhat of a waste, the PM7 is the best one you can get, which also happens to be OEM for the JDM and EDM ZC's.

I think the PR2 is for the DOHC VTEC Si-R JDM Civics, so i dont think it will work, im trying to remember if the B16A1 was OBD0 or OBD-I and II.
i seen on multi.org that the pr2 was euro ecu.im useing pm7 now i have tried pm6 pr4 and they both suck balls.pm7 is the best ecu for the dual cam zc. btw im useing rover zc do u know if they used a pm7 in the rover gti?or was it ran with that pr2?jdmef7 what are u saying there diff between usdm alt. and jdm one?
 

·
Registered
ef7 crx
Joined
·
322 Posts
DOHCef8si said:
jdmef7 what are u saying there diff between usdm alt. and jdm one?
I never found out for sure, i just know when the alternator from a PM6 powered EFgti was hooked up the whole car didn't like it, the revs moved steadily up and down about 800 revs and the head lights brightened and dimmed with the revs I'm no auto electrician but somthing was definately amiss. There was nothing wrong with the alternator either because it ran sweet as on the Gti.
 

·
Registered
Joined
·
110 Posts
i had that same problem with my alternator when it crapped out i put one from a d16 sohc on it and the idle began to surge so i swapped in a pm7 and it idled fine
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #12
Will a pg7 ECU work fine for smog purposes on a zc or even then euro spec a8??
 
1 - 13 of 13 Posts
Top