Honda D Series Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
936 Posts
Discussion Starter · #1 ·
alright, i got a '98 eclipse gsx that is shutting off in the middle of driving and a dead gauge cluster that works only when it's at 3k rpm and with that, chokes at 3.5k rpms. also, some lights on the cluster (i.e. srs) will come on and off in what seems to be minute intervals...what could be the problem?
 

·
The H Badge is it!
91 crx
Joined
·
5,657 Posts
I think the problem is that you bought a Eclipse in the first place ha!
lol coming from the guy with 10 posts and a bseries on a dseries forum :hammer:

but honestly if its anything like my friends 95 talon, it has hella wiring problems.
 

·
Banned
Joined
·
939 Posts
Ignition switch? Faulty grounds? Loose plugs? Inspect the engine bay in the dark of night, with the engine running, and look for any arcing. Try wiggling plugs and shaking wire bundles. Cheap and easy to do.
 

·
Registered
Joined
·
936 Posts
Discussion Starter · #8 ·
I think the problem is that you bought a Eclipse in the first place ha!
noob...

will try that night arc thing when it gets a tad warmer here in MN. -had a feeling it was loose plugs or fried harness, in either case i still hate mitsubishi crap.
 

·
Registered
98 civic
Joined
·
2,429 Posts
my friend has a 00' eclipse and the wireing on that thing was such a pain in the ass. his entire dash went down then came back up then went down ended up bein the dizzy or the alternator cant remember
 

·
yellow bar for me
viper blue 92 eg
Joined
·
3,572 Posts
i refuse to fuck with them wiring problems get so bad on those cars. i just take it somewhere else. because i will be a nut case by the time i get everything fixed.
 
1 - 12 of 12 Posts
Top