Honda D Series Forum banner

1 - 5 of 5 Posts

·
Registered
1991 Honda CRX
Joined
·
3,714 Posts
Discussion Starter #1
Alright I know this doesn't really fit on D-series, but I could use some help. I got a 90 integra, I took the interior apart to clean it up and I installed some new parts. Here's what I did to it:
-took out battery, cleaned battery cables.
-Replaced spark plug wires, spark plugs
-took off the gauge cluster cover
Now the gauge cluster doesn't work (no lights except battery light, brights light, and speedo). The background gauge cluster lights work, but the tach and fuel and water temp gauge don't work. There is other parts like the rear defrost, reverse lights, radio, turn signals (hazard lights work), clock, and some other things don't work. The car runs great, but these things just don't work now. Is there some connection or ground that all of these share? On all of these parts they have no power to them or not even at the fuses. Any help?
 

·
Registered
68 Camaro
Joined
·
4,583 Posts
that makes your diagnostics a lot easier if you have no power to the fuse. trace back from the fuse to the underhood fusebox.
 

·
Registered
1991 Honda CRX
Joined
·
3,714 Posts
Discussion Starter #4
Okay, I found a wire coming from the ecu (someone spliced into the wire at the ecu) and it's just lying under the dash. I'm guessing that someone couldn't figure it out, so they wired up their way. It has 12 volts and it's from the B connector, so it's probably the one for the gauge cluster. Now I can't find where it went. I need to know where the gauge cluster and all those other parts get the power from (main source) so I can hook it up. Any ideas?
 

·
Registered
1991 Honda CRX
Joined
·
3,714 Posts
Discussion Starter #5
Found the problem, I guess that they all get power from one place...back-up light fuse. I didn't think of looking there, but the fuse was blow, replaced it, fixed some wires and it worked. Word of advice to anyone reading this, check every last fuse.
 
1 - 5 of 5 Posts
Top