Honda D Series Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Finished the build, and the code p1506 is still there(when I got the car it already had that code, as well as 6 more codes).... Ive searched but to no avail.. Ive checked..

All vaccum lines
All connections
The connections on the computer(looks fine no visible mods)
Checked the idle air control valve, looks brand new?


The car idles at about 1800rpm and you can hear the rpm drop slighly and come back up constantly... Help will be highly apreciated!
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
********Correction*********

The code is "P1508 Manufacturer Control"

This is the last code I have left... And it a pain in the a$$, ive checked and checked and nada... Well...

THE ONLY WAY i can clear the check engine light, is by NOT connecting the alternator cables.... What..???? And when the alternator is disconnected the check engine light is gone... BUT the battery icon in my dash doesnt come up......

Even though disconnecting the alt, clears the check engine light, I can still hear the car with a slight idling problem..

Lastly I managed to lower the idle, with the adjustment screw, although the idle sounds kinda ok now, I can still hear sudden rpm increases and decreases, not a lot, increases and decreases by about 100-150

Tomorrow with the alt disconnected, im going to disconnect the air control valve and see if I can get a code, if not im going to check the cables, and lastly see if I can get my hands on a new ecu..

Any other suggestions?
 

·
Registered
Joined
·
0 Posts
Have you tried unplugging the IACV to see if it makes a difference?...........Have you tried taking the valve off and cleaning its ports?...As for the code not clearing after u do these things...lets just hope the ECU didnt take a rest
 
1 - 5 of 5 Posts
Top