Honda D Series Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
hi evryone. i just recently did a d series swap from a y7 to y8 i did the full swap with the wiring harness and ecu. so my 96 ek is vtec now. but theres a problem my speed sensor, rpm and vtec isnt workng. im pretty sure its a wiring issue. and theres a fuse that keeps popping everytime i start the car i think thats the problem but dont know how to fix it. ive looked at the fuse diagram and its fuse #31 that keeps popping. can anyone please help me??
 

·
OMG TOTALLY COOL TITLE!!!!
88 y49 crx
Joined
·
3,888 Posts
hi evryone. i just recently did a d series swap from a y7 to y8 i did the full swap with the wiring harness and ecu. so my 96 ek is vtec now. but theres a problem my speed sensor, rpm and vtec isnt workng. im pretty sure its a wiring issue. and theres a fuse that keeps popping everytime i start the car i think thats the problem but dont know how to fix it. ive looked at the fuse diagram and its fuse #31 that keeps popping. can anyone please help me??

What year did the swap come out of? Bc there is obd2a and obd2b that could be the problem. Also why not just keep your stock harness and wire in vtec?


Blackd16hatch search every one of your questions has been answered many times on google and on here, don't be a lazy ass and search before you post especially when thread jacking
 

·
Registered
Joined
·
98 Posts
What year did the swap come out of? Bc there is obd2a and obd2b that could be the problem. Also why not just keep your stock harness and wire in vtec?


Blackd16hatch search every one of your questions has been answered many times on google and on here, don't be a lazy ass and search before you post especially when thread jacking

...Wasn't asking for myself, was a way of me saying to the poster of thread..."well what does fuse #31 go to", meaning if he knows this, then this may be the root of the problem and this will be relative to why he made thread in first place....If I needed to know myself i'd google in a heartbeat, but I didn't need to know. Since he was speaking about it, I figured I'd converse on thread by asking, and if he knew, then i may of known more about what #31 went to and possible complications of the mechanism of whatever #31 went to

What is thread jacking? meaning not to ask Q's for myself when on someone else's thread? I understand now,,,,if it's their thread then should focus on why they threaded...Thanks for advice si-hatch86...will thread my own from now own, and keep threads relative to the poster.
 

·
B-series Destroyer
4g 4d civic
Joined
·
913 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #6
rico58204 is right thats what the fuse leads to. the swap took me and my dad about 7 hours, and the swap is from a 99 si into a 96 hatchback. i didnt use the stock harness because the harness was already attatched to the vtec swap. so this swap was basically "plug and play". i just need to know if someone evr did a swap like that before and came across the same problem or if someone is really good with electrical and can tell me what i can do to fix this issue based on the information i provided.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Im using the ecu and wiring harness that came with the 99 si motor. also i rememberd i came across another problem, my coolant fan wouldnt come on so i used a few wires, installed a button and manually turned the fan on when i felt the car needed it. so the problem has to be something involving my wiring harness. the harness has only 2 plugs that plug into the ecu, but he ecu has 3 slots...so is the 3rd plug missing a problem or is that normal?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
True...so do you think i should get the wiring checked by someone who knows what there doing, or is there a way i can rewire my rpm,speed sensor and vtec?
 

·
Registered
ej8
Joined
·
6,365 Posts
True...so do you think i should get the wiring checked by someone who knows what there doing, or is there a way i can rewire my rpm,speed sensor and vtec?
Just get the right harnesd. Where is ur old harness?
 

·
Registered
ej8
Joined
·
6,365 Posts
I sold the harness with the old motor, i still have the old ecu but i don't think that would help with anything because its non-vtec.
Sucks.
Your going to have to find a 96-98 motor harness. Vtec for ease but non vtec will work but your have to splice in knock srnor and vtec wiring.
Also tell me your not using the y7 injectors with a y8 ecu?
Y7 injectors r 190cc. so if u got those n ur need some y8 240cc injectors.
 

·
\/ apply baby lotion here \/
'98 Civic 4 Door
Joined
·
11,260 Posts
and the swap is from a 99 si into a 96 hatchback. i didnt use the stock harness because the harness was already attatched to the vtec swap. so this swap was basically "plug and play".
fail. It's off a 99 Ex Civic. If it was a Si, then you would have a B16a in your hatch right now. It can't be plug and play because your cabin ecu plugs can't plug into a 99-00 Ex p2p ecu. Connections and plugs are different...


Im using the ecu and wiring harness that came with the 99 si motor. so the problem has to be something involving my wiring harness. the harness has only 2 plugs that plug into the ecu, but the ecu has 3 slots...so is the 3rd plug missing a problem or is that normal?
that is NOT normal. Here is your answer from my post above...


so do you think i should get the wiring checked by someone who knows what there doing, or is there a way i can rewire my rpm,speed sensor and vtec?
NO. Don't waste time or money to get that engine harness checked out. It's not going to work for your 96 hatch...



I sold the harness with the old motor, i still have the old ecu but i don't think that would help with anything because its non-vtec.
Fail again! and true LOL.
that p2e ecu will not plug into that OBD2b engine harness. It would help you for the mean time if your engine harness would have been D16y8 OBD2A Engine harness. But you would have switched to y7 fuel injectors...


All n ALL, you will need to get yourself a OBD2a D16y8 engine harness. I have one for sale but you can not view the for sale section yet. And the only one little problem you're going to have if you use a stock OBD2a D16y8 engine harness is wiring up the secondar o2 sensor. On Ex/Si models, the secondary o2 sensor plug comes from inside the cabin straight out the bottom of the car...

I say get your old y7 engine harness back (IF YOU COULD) and get with your Dad so you guys can figure out how to convert it to vtec. Or at least put it on your car right now with your old y7 ecu so you can roll for now. Don't forget about the y7 fuel injectors...
 

·
OMG TOTALLY COOL TITLE!!!!
88 y49 crx
Joined
·
3,888 Posts
fail. It's off a 99 Ex Civic. If it was a Si, then you would have a B16a in your hatch right now. It can't be plug and play because your cabin ecu plugs can't plug into a 99-00 Ex p2p ecu. Connections and plugs are different...



that is NOT normal. Here is your answer from my post above...



NO. Don't waste time or money to get that engine harness checked out. It's not going to work for your 96 hatch...




Fail again! and true LOL.
that p2e ecu will not plug into that OBD2b engine harness. It would help you for the mean time if your engine harness would have been D16y8 OBD2A Engine harness. But you would have switched to y7 fuel injectors...


All n ALL, you will need to get yourself a OBD2a D16y8 engine harness. I have one for sale but you can not view the for sale section yet. And the only one little problem you're going to have if you use a stock OBD2a D16y8 engine harness is wiring up the secondar o2 sensor. On Ex/Si models, the secondary o2 sensor plug comes from inside the cabin straight out the bottom of the car...

I say get your old y7 engine harness back (IF YOU COULD) and get with your Dad so you guys can figure out how to convert it to vtec. Or at least put it on your car right now with your old y7 ecu so you can roll for now. Don't forget about the y7 fuel injectors...
it would be si if he is from our nothern friends (canada) lol had to point that out
 

·
Registered
Joined
·
7 Posts
Discussion Starter #18
ya i figured it out, my cars set for obd2a and the motor is obd2b...so fuck it, im just gonna save up some money and drop a b series motor in it...and btw PATA i am canadian and b16's come from sir's not si...
 
1 - 18 of 18 Posts
Top