Honda D Series Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I just got the D16Y7 out of my Del Sol & Put a D16Y8 motor in. I have run the wires for VTEC, Knock Sensor, etc. I have unloomed the wiring for the 2nd 02 sensor because as you know the Y8 exhaust has the sensor in the tunnel. When I plugged the sensor in I'm getting code 65 for sensor heater. I have tried about 3 different o2's with the same problem. I checked the pinouts on the ecu and the only thing I see is that the grounds for the o2's (for primary and secondary) are swapped. (IE Sensor Ground for Primary o2 is in pin 11, Sensor Ground for Secondary is in pin 12.) Would this make a difference as they are both just grounds? I was going to swap the pins back however pin 12 is bigger then 11 and will not fit in the connector. Any help would be greatly appreciated :wacko:
 

·
Registered
1997 Civic Hatch D18Y8 M62 S/C
Joined
·
2,664 Posts
I did a very similar modification when I swapped a Y7 for a Y8 in a Civic. I swapped the P2E ECU for the P2P ECU but I used a Y8 harness which does not have the secondary O2 sensor wired into it. So my question is what harness are you using?

And which connector are you refering to?

According to the FSM: Connector D
pin 11 = sensor ground
pin 12 = MAP sensor ground
pin 13 = secondary O2 sensor ground

All pins are the same size.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5 (Edited)
I did a very similar modification when I swapped a Y7 for a Y8 in a Civic. I swapped the P2E ECU for the P2P ECU but I used a Y8 harness which does not have the secondary O2 sensor wired into it. So my question is what harness are you using?

And which connector are you refering to?

According to the FSM: Connector D
pin 11 = sensor ground
pin 12 = MAP sensor ground
pin 13 = secondary O2 sensor ground

All pins are the same size.
Using my stock Del Sol wiring as it uses cannon plugs and is not a one piece like the EK I got the motor from. The connector was D Pin 11 which is Green/Blue is actually in the Pin 12 spot. However Pin 12 is to large to fit in the Pin 11 slot. I think I may have confused the SG1, SG2 pins as o2 ones for some reason I will check pin 13 when I get home.
 

·
Registered
1997 Civic Hatch D18Y8 M62 S/C
Joined
·
2,664 Posts
Dude, I'd like to help you out here but you need to clarify a couple of things for me.

What do you mean by "cannon plugs"? What's not in one piece like the EK?

Pins 11, 12, and 13 in my Civic FSM matches what's in the link you provided.

Pin 11 SG2 Green/black
Pin 12 SG1 Green/white
Pin 13 SHO2SG red/yellow (D16Y7 ), green/black (D16Y8 )

Is that what you have?

As far as your speedo is concerned - one problem at a time...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10 (Edited)
I got the speedo working fine now so thats fixed.

Ok the 98 Civic EX Coupe uses a one piece engine harness that goes from the motor straight to the ECU. The Del Sol uses Cannon Plugs that look something like this.



So it is a two piece harness, the connectors from the engine plug into the cannon plugs which then plug into the ECU. Some of my colors do not match the link I posted above. However I found a pinout topic on Honda Swap that matches the wires I have, but conflicts with the pinout diagram above.

Example:

FFS Tech VSS Says Orange (Teg Which uses cannon plugs like the sol) or Blue/White (Civics)
Honda Swap VSS Says Yellow/Blue which is what I have.
 
1 - 13 of 13 Posts
Top