Honda D Series Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i got a civic for dirt cheap, soo, the previous owner put a d16a6 into the civic, its driving me crazy since i have a idle problem it goes between 1k and 2k when warm, i figured it was an easy fix, wrong, i changed the iacv twice cleaned the tb real good, map sensor, tps, and even checked for vacuum leak, changed gaskets nothing its got a y8 manifold and running a p2p ecu, i got a p06 with the jumper harness and that didn't help any, with the p06 the rpms and speedometer won't even flinch, and the idling starts going even faster immediately after turning the car, what could possibly be!, im not expert so please anything would help! thanks in advance
 

·
Registered
92dx-turbo 92cx-pimp
Joined
·
89 Posts
had this issue like 10 years ago i bet if you start the car and cover the IACV hole on the ThrottleBody with your finger it will stop surging.

3 ways to diagnose this,

1.
remove intake i.e. cold air pipe, stock, short ram, ect. and with engine running cover TB with your hand if it chokes and dies its not a vaccum leak but if it doesnt you'll hear a faint wistle chase it down and fix it.

2.
when putting on the manifold you inderectly plugged something in wrong i think its the MAP and IAVC with identical plugs check those.

3.
both IAVC units were faulty and or someone tried cleaning them and destroyed the sensor inside as there not supposed to be directly hit with pressurized cleaning solvents.
did they have the O-ring on them?
most cases that is cracked and needs replacing

remember tho obd1 and obd2 are different
 
1 - 4 of 4 Posts
Top