Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
91 Hatch
Joined
·
541 Posts
Discussion Starter #1
i have a 1989 honda civic and i did a mpfi swap about 3 weeks ago and now the the car is over heating???the upper hose on the radiator gets really hot and the lower one stay cool it doesn't even get hot???so does that mean my thermenstat is bad?????and another problem is that the cooling fan is not coming on???
 

·
()*#$(*$
93 Legend L Coupe.
Joined
·
11,404 Posts
Did you install a thermostat? if not, replace it. Also, check to see if your waterpump is flowing by removing the cap (BEFORE THE ENGINE IS WARM) and seeing if the coolant flows. If not, you might have a bad waterpump. Have you mixed the coolant correctly or used pre-mix? Check your fan switch and fan itself.
 

·
Registered
Same as above
Joined
·
5,975 Posts
Start with replacing the thermostat and thermostat gasket it's not a very expensive repair. Only 2 10mm bolts and a little bit of spilled coolant. Also buy a new radiator cap while you're at it. This is all cheap insurance. if that doesn't solve the problem you could need a new water pump. about the radiator fan, if your temp gauge is going above half way the fan should come on at this point, you can try hooking up the fan directly to the battery to check that it's not the problem. Also check all your fuses and relays.
 

·
Registered
91 Hatch
Joined
·
541 Posts
Discussion Starter #5
no i didn't replaced the thermostat??? i check the fan its good!! i checked the fuse its good i even replaced it jus to be safe??where is the realy at because i can't find it?????
 

·
Registered
91 Hatch
Joined
·
541 Posts
Discussion Starter #6
the cooling fan comes on it works great now!! it was the fan switch that was bad thanks for the help
 
1 - 6 of 6 Posts
Top