Honda D Series Forum banner

1 - 7 of 7 Posts

·
Registered
99 civic LX
Joined
·
8 Posts
Discussion Starter #1
need some assistance on this one.
ive got a 97 hatch shell i picked up cheap to throw a motor in and sell for a quick profit and im having an issue getting it to start.
threw in a d15b2 my buddy have laying around. heres some details

-obd2 vtec dizzy bolted right onto the head no issues
-threw an fuel rail on i had sitting around with a pressure gauge, has fuel pressure.
-checked spark its getting spark
-all grounds have been checked, even threw a few more on to be safe
-all fuses are good
-firing order is correct
-using a z6 intake mani
-and y8 ecu

anything im missing here? everything on the harness is hooked up and she wont start up!!
 

·
Registered
96 civic cx hatch
Joined
·
152 Posts
what injector's are you running?

reason i ask, i bought a d15b2 for my 96 hatch (obd2) but i rigged it up to make a little more power with a y8 im/tb and threw the b2 fuel rail/injector's, i spent the better part of half a day messing with it and never could get it to fire up, swapped to the y8 fuel rail and it fired up first time....

distributor work's, i ran a d16y8 distributor on a d15b2 head with no issues...

BUT when you DO get it to crunk up and run, its gonna hit a wall at 5500rpm's :/
 

·
Registered
99 civic LX
Joined
·
8 Posts
Discussion Starter #7
been a few months since ive been on here but if anyones interested i did finally find the problem. shell had an alarm system hidden under the dash that was wired all haggard. messed with some of the wiring and got it to start.

and yes it did hit a wall at 5500 rpms, and i enjoyed banging it off "limiter" lol

i used z6 injectors with an AEM fuel rail and an automatic Y8 throttle body
 
1 - 7 of 7 Posts
Top