Honda D Series Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
okay so just did a jdm d15b vtec-e swap into my 94 ex coupe, used all the ex stuff such as harness and ecu, intake and exhaust mani, and trans. car has it’s quirks but it runs and drives pretty damn good. vtec engages like a mother compared to other single cams i’ve driven. my only issue is that when revving from a stand still it only goes to 4k and when driving it only goes to 6k. yes i realize it MAY BE because im on a p28 buti dont know. any insight on a solution? the only thing i have a cel for is o2.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
3,944 Posts
why not have kept the z6 head from the original engine and been back to square 1?
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
3,944 Posts
build the z6 and leave the d15b alone.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
3,944 Posts
why are you revving it while not in gear? drive it like its meant to be driven until you build a proper motor
 

·
Registered
Joined
·
19 Posts
If the engine is a vtec-e d15b the p28 will not work. The d15b vtec-e uses the same wideband the VX comes with in the USA. You will need the correct ecu. Do you have a CEL?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
If the engine is a vtec-e d15b the p28 will not work. The d15b vtec-e uses the same wideband the VX comes with in the USA. You will need the correct ecu. Do you have a CEL?
yep. CEL for o2. lol. i knew all of this but the other thing with the vtec-e (p06) ecu is that it calls for an egr valve.....and my z6 mani doesnt have one.
 
1 - 8 of 8 Posts
Top