Honda D Series Forum banner

1 - 20 of 31 Posts

·
Registered
88 Honda CRX Si
Joined
·
217 Posts
Discussion Starter #1
Ok, finally got my car built n boosted...

a6 built top n bottom...
t25 garrett
aem tru boost controller
neptune rtp demon board
etc...

No boost leaks...

This is my problem:

When on the dyno we turned up the boost to a lil over 10psi to start making more power... car pulls good and strong, lines are good n smooth, once the boost gauge reads 10.1 psi the car hits like a boost cut or sputters as if it a boost leak or something so we have to shut it down... You can set it to 10.0 or 9.9psi and the car pulls all the way to redline good and strong... Is this a wastegate issue? We believe its something not correctly set on the AEM TRU Boost controller, its a lil tricky to understand... Any suggestions are appreciated Thanks. :yes:
 

·
Registered
97 honda coupe
Joined
·
7,611 Posts
Ok, finally got my car built n boosted...

a6 built top n bottom...
t25 garrett
aem tru boost controller
neptune rtp demon board
etc...

No boost leaks...

This is my problem:

When on the dyno we turned up the boost to a lil over 10psi to start making more power... car pulls good and strong, lines are good n smooth, once the boost gauge reads 10.1 psi the car hits like a boost cut or sputters as if it a boost leak or something so we have to shut it down... You can set it to 10.0 or 9.9psi and the car pulls all the way to redline good and strong... Is this a wastegate issue? We believe its something not correctly set on the AEM TRU Boost controller, its a lil tricky to understand... Any suggestions are appreciated Thanks. :yes:
Sounds like he is using crome and is hitting the boost cut. Or, you have your plugs gapped too wide and your getting spark blow out.
 

·
Formally known as SPONSOREDCRX
Joined
·
3,566 Posts
stock map?
 

·
Registered
88 Honda CRX Si
Joined
·
217 Posts
Discussion Starter #5
Tuned on NEPTUNE RTP w/ demon board... hondata 4bar map sensor... Good parts, no cheapies.
 

·
Registered
88 Honda CRX Si
Joined
·
217 Posts
Discussion Starter #7
no boost cutoff, that is not enabled, pretty sure its something to do with the aem truboost settings. We doubled check all the features in neptune, its setup correctly
 

·
Registered
97 honda coupe
Joined
·
7,611 Posts
no boost cutoff, that is not enabled, pretty sure its something to do with the aem truboost settings. We doubled check all the features in neptune, its setup correctly
Try removing the connector on the EBC and see if you can get over 10psi (if you cant safely do that then well have to go about that another way.)
 

·
Registered
92 Civic Hatch
Joined
·
1,757 Posts
Check the gap on your plugs man!!!!! even if the EBC was connected wrong, it wouldnt cause your engine to sputter, it would just limit the boost to a certain level or not even work at all. the True boost doesnt even connect into the Ecu does it? even if it had PWM that wouldnt cause anything like this to happen unless you had a boost cut enabled...but you already said you didnt....So I would say plug gap sounds like a likely cause! especially at 10psi, i had same problem. till i gapped em down!
 

·
Registered
88 Honda CRX Si
Joined
·
217 Posts
Discussion Starter #14 (Edited)
Ok....

We checked the plugs, he showed me the timing marks, i'm not to familiar with tuning and timing but he told me we could add more timing to the cam b/c we were no where near the threshhold... I do not recall him checking the gap but I did see him gap the plugs before he installed them, so I will run that by him.

The ebc is properly connected. We checked the lines on the solenoid as well, all good.

When the truboost duty cycle is set from 60%(8-9psi) to 70%(10+psi, dont know exactly b/c it cuts) the car starts to build boost, line on dyno screen is clean n climbing, hits 10psi and cuts. It hits and cuts at 10psi on the dot like clockwork. Neptune has been set at 16psi, 20psi, and still no increase in pressure. You can turn the truboost down to 60%, 8-9 psi and she pulls good, hard, n strong to redline.

My setup is made to handle much more boost, so is the turbo.
 

·
Registered
88 Honda CRX Si
Joined
·
217 Posts
Discussion Starter #16
Wouldn't the car blow out/cut at different pressure levels? Why 10.0psi on tha dot every pull?
 

·
Registered
88 Honda CRX Si
Joined
·
217 Posts
Discussion Starter #18
running fj rods and vitara pistons. supertech springs n retainers, stock valves, stock port on head, bisimoto 1.2 non vtec turbo cam, and 75.5mm bore
 
1 - 20 of 31 Posts
Top