Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
My EK?
Joined
·
213 Posts
Discussion Starter #1
I just replaced a head gasket, water pump, and thermostat on a 95 ex. Also flushed out the radiator and it's flowing well. I start the car and get it to normal operating temp and the thermostat opens but coolant will not flow through the lower radiator house. There are no blockages anywhere and the head was taken to the machine shop and milled and pressure tested. Any ideas on why the coolant isn't circulating?
 

·
Premium Member
Red '95 EX
Joined
·
1,066 Posts
are you sure all plugs to the thermo are correctly hooked up? try taking the thermo off and see if you can get water to flow then. might be either a blockage (even tho you say there isnt) or the thermo isnt properly opening up.
 

·
Registered
My EK?
Joined
·
213 Posts
Discussion Starter #3
no blockages or anything but we did get it fixed. i guess there was a fairly large air lock somewhere behind the thermostat. i shut the heat off and the temp gauge dropped right down to normal, topped it off with coolant and done deal.
 

·
Registered
My EK?
Joined
·
213 Posts
Discussion Starter #5
yeah, still got it and after months and months of different issues it's finally running pretty decent!
 

·
Registered
civic
Joined
·
2,211 Posts
hell yeah bro thats awsome. i have a ek 4dr auto as the family car lol. z6 bottom end y8 head. still no vtec. but i'd like to put a 5spd in it but cant find what i need in my price range!!

i was near by ur shop the other day but i couldnt remeber for nothign where it was lol. i was at the mcds at that fucked up intersection
 
1 - 6 of 6 Posts
Top