Honda D Series Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey d series people got a issue with my D16y8 and was hoping to get some insight. My car on a cold start will start fine, but idle goes to 1k then slowly goes to 1800. Then if I hit the gas itll catch at 100 then climb back. This idle issue only happens till the temp needle starts to move.
Also another issue I am having is hesitation. Most of the time when I first put it into first and try to move, it hesitates badly unless I floor it. This mainly happens when cold but sometimes will occur when starting when cars warm.
I have had spark plugs,wires,rotor,dizzy cap, ignition coil, ect sensor and the tps replaced. I have cleaned the IACV and made sure there was no air in the coolant. Only code im throwing is knock sensor, code isnt for faulty sensor.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
So now im throwing lean codes. Im thinking that might be causing my cold start issues. Any suggestions anyone?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I dont hear any leaks and my mechanic who is a reputable honda mechanic has said there is no leaks.
 

·
Registered
Joined
·
650 Posts
I dont hear any leaks and my mechanic who is a reputable honda mechanic has said there is no leaks.
Typically, you won't hear a vac leak unless it's really bad. It's easy to check for.

EDIT: Plus, it's pretty normal to see your idle over 1000 for a cold start, especially if it's cold outside. That doesn't sound like a problem...

EDIT 2: It's probably your o2 sensor.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I understand the high idle, but its supposed to shoot straight to 1800 rpms. Now itll fluctuate till engine temp rises. Im getting a lean code and all my plugs are different colors now. Ill have the o2 sensor looked at
 

·
Registered
Joined
·
650 Posts
No offense, but you're having this stuff looked at!? Why not do it yourself, and learn something about your car.I started doing my own work because I don't really want someone digging around in my car, screwing it up. That's happened already, can't remove the plenum cover on my 91 because of it...

And that gives you another (possibly marketable) skill that can help later on.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
I dont have the tools for it and due to money issues, I dont wanna mess something up like I did before with another car project. I have no car knowledge lol. However, its not the sensor.
 

·
Registered
Joined
·
650 Posts
I dont have the tools for it and due to money issues, I dont wanna mess something up like I did before with another car project. I have no car knowledge lol. However, its not the sensor.
With everything you've had replaced, that wasn't the cause of your problem, you've probably spent four to five times the amount of money you'd have spent on proper troubleshooting and diagnosis. We're trying to help you, but all we're doing is helping your mechanic, through you...

Did you try anything stupid simple like the fuel filter? Or maybe your injectors are clogged...



EDIT: Quite honestly, if your mechanic is just replacing parts instead of troubleshooting, stop wasting your money on him. He's just taking you for a ride.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Well i have put some injector cleaner in there but didnt notice a difference. Strangely enough, i just replaced my plugs and wires about 5mins ago cuz thats all i really know how to do and it ran alot better. The old ones had a lot of black stuff on em which makes me think theres oil getting to them.
 

·
Registered
Joined
·
650 Posts
Carbon build-up usually means it's running rich. When you're too lean, you'll see more of a whitish/yellowish color, kinda powdery, even.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
Update: When I started the car this morning after it sat over night, it sounded and felt a lot better. Still had the idle issue but my hesitation was completely gone and was able to drive without issues, so the spark plugs and wires were definitely an issue.
 

·
B-series Destroyer
4g 4d civic
Joined
·
913 Posts
1 - 16 of 16 Posts
Top