Honda D Series Forum banner

1 - 13 of 13 Posts

·
nonvtak ftw
Joined
·
5,230 Posts
Discussion Starter #1
I read aound and am not really finding anything that fitting my problem.
I have a 98 civic dx hatch, it had the D16y7 and i recently swapped the B18B obd1 and every now and again I'll get the cel to come on while driving around 3k rpms. now when i shut the car off anf turn it back on the lights gone. After checking the light its a code 43. When i did the swap i think my dumbass may have accidentally put the d16y7 primary 02 sensor in. would that have anything to do with my problem. the cars runs fine. doesnt stumble on acceleration or anything like that. sometimes when i start the car when its cold out it may have an awkward idle. Also i seem to notice the light may come on more often when its cold out then when its hot. The fuel filter is new so i already ruled that out. injectors either work or they dont so there pretty much ruled out. and the fuel pump i cant see taking a shit after i did a swap. the car only has 100k on it. anyone have any suggestions. im leaning toward the 02 sensor maybe being a civic's instead of an integras. also running obd2-obd1 with P75 ecu.
 

·
Registered
Joined
·
2,638 Posts
o2 is probably dieing on you, the fact that it is from a civic and not an integra wont have anything to do with it...get a new one
 

·
nonvtak ftw
Joined
·
5,230 Posts
Discussion Starter #4
now that im thinking about it. Would'nt the cel be more consistant if it were an 02 sensor? and without a cel on why would it idle slightly lopey sometimes?
 

·
nonvtak ftw
Joined
·
5,230 Posts
Discussion Starter #8
Code 43 is translated to fuel supply system. The book says to check the fuel pressure and the fuel pressure regulator. But im gonna change the 02 by weds.
 

·
Registered
Joined
·
2,638 Posts
check the fuel system first...if nothing then replace o2 and see if that helps...as to why the idle is funny i dunno, i reset my ecu yestarday it it wanted to idle at 1500 once warmed up, i cut the car off, cranked it back up idled normal....
 

·
Registered
Joined
·
302 Posts
might replace the fuel pressure regulator, these rarely go out, as far as idling weird id say TPS, my wifes for the longest time would throw a tps sensor dirve it for a week and code would come back on, I replaced it with another tps i had laying around and it fixed the problem.
 

·
nonvtak ftw
Joined
·
5,230 Posts
Discussion Starter #13
i have another throttle body laying around i'll put it on and see if theres a differance. im gonna go pick up a B&M regulator also by mid week.
 
1 - 13 of 13 Posts
Top