Honda D Series Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
867 Posts
Discussion Starter #1
OK i bought a BRAND new vtec solenoid, code 22 went away, but now im showing code 21. which is vtec solenoid unplugged or something like that. but see my vtec oil sensor is plugged into the ECU but Vtec activation, is plugged into a switch, could this be why? i tried with the switch on and switch off and it still shows 21. how can i fix this?
 

·
VTEC withdrawals
i "ride" yo momma
Joined
·
1,339 Posts
wow...if you really must...when you go to get it smoged just take the cluster off and pull the check engine light out. i suggest fixing it tho. your wiring it to the correct spot. i had a code 22 or 21 with my vtec wired till i got off my ass and spliced in a vtec light.
 

·
VTEC withdrawals
i "ride" yo momma
Joined
·
1,339 Posts
are you sure the solenoid works? run a 12v hot lead to it and listen for a click.
goto autozone and get a 12v single led red bulb its dirt friggin cheap...cut a patch of the coating off your vtec wire coming off the ecu...wrap the wire around it and cover with electrical tape. the bulb will need a ground also.
 

·
VTEC withdrawals
i "ride" yo momma
Joined
·
1,339 Posts
its gotta work, its a BRAND Spanking new solenoid from Honda. but i will try the LED thing. if all else fails ill pull the bulb from the gauge cluster. do you happen to know what bulb it is?
um not really....when you pull the cluster just note the location of the cel and you should be golden. you may wanna run that hot lead just to double check....sometimes brand new can still be bad. just use some scrap wire.
 
1 - 9 of 9 Posts
Top