Honda D Series Forum banner

1 - 3 of 3 Posts

·
Hondaphile
see above
Joined
·
1,113 Posts
Discussion Starter #1
Ok...I'm getting code 15 intermittently in my car. I believe it comes up as "missing or improper ignition signal". It doesn't seem to be affecting the idle or driveability. I'm just concerned with figuring out what is causing it and fixing it. I think I can get someone to overlook the CEL for my inspection (generally, if you have a CEL they will fail your inspection out of hand...regardless of whether the CEL has anything to do with emissions)

I'm just asking if anyone has had this issue and if so, what caused it, what fixed it? Any information would be greatly appreciated.

Thanks
 

·
nonvtak ftw
Joined
·
5,230 Posts
Assuming that your obd1 your getting code 15 (ignition output signal)

I would start by checking components of the dizzy. Coil test, ICM test. Swapping it out with another of course would be the quickest way to narrow it down.

BTW just some info you can learn today... Every CEL has to do with emissions
But the year car you have decides what they look for in an emissions test.

For instance if you drive a car made 96 or after it has obd2 and will be plugged into there emissions machine which is looking for on or stored CEL's also a gas cap test and in some cases thank god not mine smog tested.

A car made before 96 (lucky bastards) will only be getting a visual emissions test. This is where the mechanic will be looking to see that your exhaust does not leak, has a cat and 02 sensors and egr are there and in working condition.
 

·
Hondaphile
see above
Joined
·
1,113 Posts
Discussion Starter #3
Thanks. And I know that in technicality CEL's have to do with emissions, I was a for a number of years licensed to do inspections in the state of Texas so I know a bit about it, however after having it on the sniffer (OBD1 cars in certain areas of Texas have to be emissions tested) and having it pass by emission standards, but not passing due to the CEL being on, I don't consider it to be an emissions issue. Everything else on the car passes the visual inspection. As far as the Distributor, the coil rotor cap and wires are all new....only possible component would be the ICM, and for that I had a friend check it in his shop as he had the best tools of the two of us....nothing there.

So, you're advice beyond all that would be a different distributor then.....

oh, and thanks for teaching me something new :p
 
1 - 3 of 3 Posts
Top