Honda D Series Forum banner

1 - 12 of 12 Posts

·
Registered
1995 4dr w/ z6
Joined
·
5 Posts
Discussion Starter #1
So I installed a new clutch, flywheel,tb, pressure plate yesterday. Nothing new been working on hondas since the early 90s( yes I'm old) but never have I had one that sounds like a rod knock after being replaced. It is a bit quieter with clutch depressed but not much. All parts are brand new and royal purple fluid was changed...any ideas...I'm going to pull it back off today but it sounds bad
IMG_20201220_144310079_HDR.jpg
 

·
Registered
1995 4dr w/ z6
Joined
·
5 Posts
Discussion Starter #3
Will do...it sounds like something is hitting...good possibility... looking like I can't pull it till Christmas Eve...16 hr work days are too long
 

·
Registered
Joined
·
6,411 Posts
I think I see part of the problem, its the white label on the bottom left of the picture.

jokes aside, why didnt you grab a cheap Exedy Pro kit?


Few bucks more than the ebay stuff, and abolutely OUTSTANDING upgrade in quality and durability. Heck, people have taken them past 200whp, and its supposed to be a stock style repalcement.


When you have it apart, look for anything shiny or dented.

Also check the springs and the TABS that hold the springs of the clutch.

did you torque the flywheel botls that hold it to the crankshaft?

Also make sure the clutch is facing the right way. Ive seen the labels be backwards on some of the cheap parts, so even if you following all markings and tags to the T, it can goof you at times.
 

·
Registered
1995 4dr w/ z6
Joined
·
5 Posts
Discussion Starter #5
Ya it is a cheaper part but I've used it before on a nitrous build with good results. I torqued to 87 on the flywheel and used a stethoscope last night sounds like it's hitting up top of the bell housing so when I pull it tomorrow I am gonna check everything out. But hopefully it will be simple and then I can slap the turbo and tune her.
 

·
Registered
Joined
·
6,411 Posts
hey, if you have used it with success, dont let someone downplay it.

Ive just had personally bad luck with the cheap stuff. flywheels severely out of balance, clutchs popping the spings off due to broken or bent tabs, even got a clutch disc with 8 pucks, and 2 of the pads fell off in shipping! The rivets were not even on it.
 

·
Registered
1995 4dr w/ z6
Joined
·
5 Posts
Discussion Starter #7
So pulled everything apart...guide bolt was it...never had an issue with that in the past. But easy fix I appreciate the input from everyone.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
4,743 Posts
and that's why bone is the best
 
  • Like
Reactions: EFB055

·
Brokedick Millionaire
Joined
·
40,576 Posts
Customer and former member on here had the exact same problem earlier this year. Disengaging the clutch (pressing on the pedal) moves the crankshaft enough to stop the noise.
 

·
Registered
Joined
·
324 Posts
So pulled everything apart...guide bolt was it...never had an issue with that in the past. But easy fix I appreciate the input from everyone.
Did you put a crush washer on the guide bolt or anything? Anything that changes how much it sticks out can cause this.
 

·
Brokedick Millionaire
Joined
·
40,576 Posts
Did you put a crush washer on the guide bolt or anything? Anything that changes how much it sticks out can cause this.
Common mistake. The 2mm crush washer is just enough to cause headaches when it shouldn't be there in the first place.
 

·
Registered
1995 4dr w/ z6
Joined
·
5 Posts
Discussion Starter #12
No there was an o ring on it I pulled off...works great now clutch feels perfect new detent springs helped alot. Got engine internals done exhaust done trans done suspension done gutted now just need some boost and I'll be track ready...
 
1 - 12 of 12 Posts
Top