Honda D Series Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all,

I am new to this forum and this is my first post and I needed some help I have got a civic ek3 d15z6 and I was having a problem with no power at low rpm even when putting foot down it’s struggling up any gradient hsbing to down shift to get up but vtec kicks in as it should and pulls well.
Before my ownership it was running a d16z6 head on it with the d15z6 bottom end and was boosted I had to change engine due to head gasket failure I bought the d15z6 complete engine and was fitted but now having this issue with replacement engine of no power at low rpm or pick up.

any advice will be appreciated

thanks
 

·
Registered
93 4d lx, z6,ported, port matched, compression bumped, balanced, manual swap
Joined
·
938 Posts
Did you happen to change the ecu when you swapped to motor? A stock engine isn't going to run right on an ecu tuned for a boosted and modified engine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Did you happen to change the ecu when you swapped to motor? A stock engine isn't going to run right on an ecu tuned for a boosted and modified engine.
Hi yes it had happened when engine was changed

Did you happen to change the ecu when you swapped to motor? A stock engine isn't going to run right on an ecu tuned for a boosted and modified engine.
No ecu wasn’t changed not sure about what ecu is on there
 

·
Registered
Joined
·
1 Posts
Hi all,

I am new to this forum and this is my first post and I needed some help I have got a civic ek3 d15z6 and I was having a problem with no power at low rpm even when putting foot down it’s struggling up any gradient hsbing to down shift to get up but vtec kicks in as it should and pulls well.
Before my ownership it was running a d16z6 head on it with the d15z6 bottom end and was boosted I had to change engine due to head gasket failure I bought the d15z6 complete engine and was fitted but now having this issue with replacement engine of no power at low rpm or pick up.

any advice will be appreciated

thanks
Check if your spark plug wires are worn out or bad, that causes alot of issues down the line.
 

·
Registered
93 4d lx, z6,ported, port matched, compression bumped, balanced, manual swap
Joined
·
938 Posts
No ecu wasn’t changed not sure about what ecu is on there
That's your issue then. Remove the ecu, open the cover and see how it was tuned for the previous engine, you may be able to have a chip burned for the stock base map, or take it somewhere that can plug in and load the base map, depending on the tuning solution used.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Hi okay that’s fine managed to resolve the issue was the timing wasn’t done properly on the engine which was causing the low rpm issue thank you very much for the replies and will be posting any problem or improvements made to my ek thanks again
 
1 - 6 of 6 Posts
Top