Honda D Series Forum banner

1 - 16 of 16 Posts

·
Registered
91 civic hb
Joined
·
88 Posts
Discussion Starter #1
i have an electrical or timing problem.. runs perfect untill the check engine light comes on then it cuts out in between each gear and wont go over 80 its drivable for m=now but frustrating i bought a used distributer but was told me top dead level sensor is bad and thats what my computer flashes which is 8. if im cruising down the road and turn my key off and back on it resets and drives fine as long as im accelerating then once i slow down the light comes back on. anyone know some solutions?
 

·
Registered
91 civic hb
Joined
·
88 Posts
Discussion Starter #5
ive done this tho i know its a used distributer or dizzy but is there any chance my time belt is off or somethin else
 

·
Registered
91 civic hb
Joined
·
88 Posts
Discussion Starter #7
well didnt know it until i drove it again and found what the code meant so changint that module or sensor should fix my problem i just left pep boys today tellin them i needed that part and they said it shouldnt be that since i drove the car there. they said it wouldnt be getting spark or be running
 

·
I no longer haz teh pink eye! Iz got STINK EYE
Joined
·
3,332 Posts
its not the timing belt since it runs fine then it messes up, sure sounds like a bad dizzy.
 

·
I no longer haz teh pink eye! Iz got STINK EYE
Joined
·
3,332 Posts
well a reman isnt brand new its a rebuilt one, distributor-king on ebay has gotten some pretty good reviews.

edit: you can go here to http://www.distributorking.com/
 

·
I no longer haz teh pink eye! Iz got STINK EYE
Joined
·
3,332 Posts
np sleepciv got ya the right track. these things can be a booger to pin down sometimes. good luck with it
 

·
Registered
91 civic hb
Joined
·
88 Posts
Discussion Starter #16
o im not for that old of a car it costs like 75 anyways so i rather have a gararge look at it and determine the problem
 
1 - 16 of 16 Posts
Top