Honda D Series Forum banner

1 - 20 of 23 Posts

·
Registered
89 hatchback
Joined
·
33 Posts
Discussion Starter #1
My car keeps eating turbos and I don't know why. The turbos
I've been using are used but I think are good. I got like the eBay manifold
eBay wastegate turboxs blow-off valve. Any ideas y this is happening.
 

·
Premium Member
2005 Legacy GT
Joined
·
1,754 Posts
How precisely are they getting eaten? Information is helpful if you want help determining the cause of something. With the information you've given us I'd say ... stop feeding your car turbos. But since I'm pretty sure you just mean they're breaking ... again I'm basing this advice on the veritable plethora of data I've been given ... stop hitting the damn things with an eight pound sledge.
 

·
Registered
'97 crv
Joined
·
1,467 Posts
My money's on poor oil supply and or drain. Only determinable with more info.
 

·
Registered
89 hatchback
Joined
·
33 Posts
Discussion Starter #10
oil pressure
oil feed line size
oil being used
oil drainage
over shaft speed
Oil pressure 80 when cold 50 when warm
Feed line- I think -4 an
Return line- 3/4 hose
Oil- castrol something
Well what is happening is a variety of different ways the car
Breaks turbos. I've gone through about 4 of them. First one never
made boost. All fins were good so changed it then the next one started good and just smoked like crazy. The next 2 when I rev the car when I released the gas the turbo would violently stop then shaft was messed up.
1. eBay turbo
2. Turbonetics.
3.4. Garret
Waste gate eBay blowoff valve greddy
 

·
Registered
'97 crv
Joined
·
1,467 Posts
first one. cuz it was an ebay.
2nd one, blown seals, couldve been done before you got it
3 and 4....... could you describe their symptoms in more detail?

where are you getting your oil from on the block?
 

·
Registered
92 Civic Hatch
Joined
·
1,757 Posts
When the turbo violently stops after you let off the gas, its *usually* an indication your BOV is not working. Its all that boost pressure hitting the throttle plate, and traveling back down your IC piping and slamming into your compressor making it stop spinning. Its supposed to go out your BOV.

My guess is if the Ebay BOV isnt complete junk, that you have the vaccuum lines hooked to it incorrectly, or its adjusted suuuuuppper tightly.

THe other turbos smoking etc, like was said, is probably seals. The first one not making any boost.... Was it internal, or externally wastegated? (or was the BOV or wastegate stuck open? LOL)
 

·
Registered
Joined
·
3,720 Posts
Even without a BOV the turbo should not stop. It will just slow down more rapidly, not nearly as much as people think.

Post pics of your setup, oil drain in particular.
Also, on the setups that made boost, did it seem to spool slow and/or have odd fluctuations in boost?
 

·
Classic Man
Civic
Joined
·
16,355 Posts
id like to see pics of the setup, pics of the oil feed (block to turbo), and pics of the oil drain and oil pan.

also like to see the air filter setup on the turbo

and also what restrictor, if any, you are using...
 

·
Registered
89 hatchback
Joined
·
33 Posts
Discussion Starter #17
Thanks everyone figured out what was wrong. My brother had put Teflon tape on the feed line fitting coming out of the block and it blocked the oil pressure. From going through and messed up the last two turbos. Puting car back to stock till can save mOney for good turbo
 

·
Premium Member
Joined
·
537 Posts
When the turbo violently stops after you let off the gas, its *usually* an indication your BOV is not working. Its all that boost pressure hitting the throttle plate, and traveling back down your IC piping and slamming into your compressor making it stop spinning. Its supposed to go out your BOV.

My guess is if the Ebay BOV isnt complete junk, that you have the vaccuum lines hooked to it incorrectly, or its adjusted suuuuuppper tightly.

THe other turbos smoking etc, like was said, is probably seals. The first one not making any boost.... Was it internal, or externally wastegated? (or was the BOV or wastegate stuck open? LOL)
I had a BOV seize up on me and I didn't notice (open dump). It ate 2 turbos... it was bad juju
 

·
Registered
Joined
·
3,720 Posts
Thanks everyone figured out what was wrong. My brother had put Teflon tape on the feed line fitting coming out of the block and it blocked the oil pressure. From going through and messed up the last two turbos. Puting car back to stock till can save mOney for good turbo
Yeeeep.
Im amazed people still dont know that youre not supposed to use teflon tape with an AN/JIC fitting...
 
1 - 20 of 23 Posts
Top