Honda D Series Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
hi, i have an ej9 with a d14a4 and d15z6 manifold. i've had this manifold for a month and the car has been running fine. i left the car for one week, and yesterday started it up and took it for a spin (before the needle got right in the middle, at operating temperature), after i took it for a spin, i left the car at idle while i filled up a tire, and all of a sudden it died on me. i presumed i had ran out of fuel even though the fuel gauge was indicating otherwise. today i filled it up, started it up, then took out the battery terminals to reset the idle, and while it was idling (from cold) for about 5-6 minutes, it all of a sudden died again. trying to start it afterwards is really rough, but still keeps a good idle, after 10 seconds though it dies again. i dont think it's an injector or ignition problem as the engine doesn't misfire at all, if anything it's running quite well. it's just that it suddenly dies for no reason. the fuel pump is 2 months old, altough it's quite a cheap aftermarket one, i've been advised to switch back to the oem one. all filters are new, oil is at level, i couldnt see any vacuum leaks, so i'm kind of dumbfounded. its a 96 prefacelift so it doesnt have any crank or cam sensors. after i had left it overnight it started right up(even better than it usually does), but after it dies it struggles to start back up.

tl;dr car starts up fine but then dies after getting up to temp and starts like crap after dying.

edit: when it dies it's just like stopping the engine, not sputtering or anything, just straight stops and that's it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
put the stock intake back on...
i dont see how the intake would cause any issues. everything is rerouted the same as before (d14a4 manifold is v. similar to y7 manifold), with the throttle body and injectors from the 1.4 manifold. it's been working fine until i let it sit.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
does the rpm drop below idle then stall or is it idling at 700-800 rpm and just shuts off?
it idles completely fine. on cold start it's around 1200 and slowly drops off to 700-800 rpm.
i've uploaded a video showing how it acts, at the middle, it's me priming the fuel pump, not any issue.

besides ordering an oem pump i'm also gonna test a distributor from another car these days.

i find it strange how the battery light flickers shortly before the engine dies out. the battery is quite old and leaky, could that cause this?

also it doesn't usually start like that. on cold start it starts right up. after dying it turns over quite a bit.
 

·
Registered
89 EF 4wd sedan
Joined
·
653 Posts
My money is on distributor. If you can swap one over to test for free, i would start there.

IMO if the fuel pump is intermittently operating the car would stumble as it's stalling as fuel pressure drops.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
My money is on distributor. If you can swap one over to test for free, i would start there.

IMO if the fuel pump is intermittently operating the car would stumble as it's stalling as fuel pressure drops.
thank you, a friend with an ej9 is coming tommorow and we're swapping the distributor to check. distributor and fuel pump are the only options i've got, as the car runs great besides that.
 

·
BATSLOMAN GIVES NO FUCKS.
Joined
·
4,544 Posts
do a compression check
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
My money is on distributor. If you can swap one over to test for free, i would start there.

IMO if the fuel pump is intermittently operating the car would stumble as it's stalling as fuel pressure drops.
hello, i've switched over the distributor and plugs from another car, it still has this problem. i m gonna switch the fuel pump back to an oem one when i get back from work tommorow. anyone have other ideas?
 

·
Registered
Joined
·
3 Posts
I’m having same issue. My car is y7 bottom and y8 head mine drives fine, but when I push clutch in and come to a stop the rpms will fall super close to 0. It will sometimes idle back up but most the time dies but then starts right back up.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #20
I’m having same issue. My car is y7 bottom and y8 head mine drives fine, but when I push clutch in and come to a stop the rpms will fall super close to 0. It will sometimes idle back up but most the time dies but then starts right back up.
this is a completely different problem, if you removed the battery ecu restarts itself. drive it more idle will find its position.
 
1 - 20 of 21 Posts
Top