Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter #1
Ok so my problem is this, Ill be driving my 98 ej ex(5 speed) and then all of a sudden when i decide to let the throttle open upon (get into vtec mode so 5k+ rev) it will make a pop noise then my check engine light comes on and it wont let me rev past 4k. Sometimes when i do get on it though this doesnt happen it only happens every other time.
I recently replaced the crank and bearings, also has I/H/E, and when me and my dad where rebuilding the motor we needed a throttle body sensor so he went and got one from the junkyard from the same engine just different model car i believe it was. Anyway does anyone know or understand the problem im having.
I think i have to re-flash my ecu but will probably get a new one because if i have to because i will bee turboing it soon anyway.

Thanks for your time

here is the sensor that we replaced

Sidenote: it basically sounds like it has a rev limiter at 4k
 

Attachments

·
Registered
Joined
·
526 Posts
Over 4k is overrated haha, I rarely go over 4k hell even 3k. But either firing order is screwed up or timing or vtec solenoid who knows. Double check them 3 an get back to us
 

·
Registered
Joined
·
3,314 Posts
What codes are you having when this happens? It will run with a bad MAP, it'll just go into limp mode and wont rev past 4k.
 

·
Registered
Joined
·
526 Posts
True didn't think of that, friend converted her hatch to obd1 an map was makin her go into limp mode a lot an would have to shut it off an restart car just to get out of it.
 
1 - 6 of 6 Posts
Top