Honda D Series Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hey guys!

My y8 is breaking up between 2500-3500 rpm, but only under moderate throttle input. At low or high throttle input it runs smooth and will get through that range easily, but when I’m about 1/3-1/2 throttle it’ll break up really bad. I’ve changed the plugs and wires recently in response to the issue, and I’m about to check the cap/rotor for signs of wear. The engine is modded with a comp cam stage 1, skunk2 IM and TB, and a full skunk 2 exhaust and untuned. These mods have been on the engine for a while with very little issues, but this problem is a recent development. Any ideas on what to check? If the cap/rotor looks wore I’ll replace them and update here afterwords.

Thanks in advanced for any and all help!
 

·
Registered
Joined
·
26 Posts
Discussion Starter #2
Also, it only happens in 2nd through 4th gear. Haven’t noticed it in 1st or 5th. And if I’m cruising around that rpm in say 3rd or 4th and go to put my foot in it, it’ll just bog and break up. I have to down shift to get it passed that range.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
So I think it is the cap/rotor that is the problem. Cap isint too bad, just minor scorching on one post, but the damn rotor is scorched pretty badly. Got new ones on order at that parts store just waiting for them to come in. Not 100% sure it’s the it’s the issue, but seeing this thing I’m pretty confident it is.
135801
2993719A-8FB1-4453-BF39-16B1D7C5694A.jpeg

135802
2993719A-8FB1-4453-BF39-16B1D7C5694A.jpeg
F73B7884-8701-4BC9-9C16-DA817CA56F31.jpeg
 
1 - 3 of 3 Posts
Top