Honda D Series Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9,921 Posts
Discussion Starter #1
So I was driving today and felt the need to pass the driver ahead of me.... in doing so I hit full boost... or wait... I only hit 10 psi on my 15g greddy turbo... My MBC and tune was set at 15lbs since last summer... how come all of a sudden it doesnt go past 10?! It sticks right on and doesnt move.... I checked the charge piping... everything was okay... check the bov.... it was okay.... is there a pin hole in my vaccuum maybe? What else could it be?!
 

·
Registered
Joined
·
1,165 Posts
Maybe check to see if the MBC is going bad...? Something wrong with the wastegate/spring?
 

·
Registered
Joined
·
838 Posts
check your pre turbo gaskets and charge piping. It might be a boost leak, if a shop has a smoke machine that would help you find a boost leak so easily. If that checks out the diaphram in the internal wastegate is most likly torn.

I had that problem before. it would make the boost but wouldnt hold it for shit. I replaced my actuator with a 19t and its been holding up 2 this day.
 

·
Registered
Joined
·
14,661 Posts
If that checks out the diaphram in the internal wastegate is most likly torn.

I had that problem before. it would make the boost but wouldnt hold it for shit.
how come all of a sudden it doesnt go past 10?! It sticks right on and doesnt move
reading owns you ;) ;) :lol:


anywho... remove the mbc and see what it does. if the psi drops to wg pressure, then the wg should be good. i would be looking at the mbc as being bad.
 
1 - 9 of 9 Posts
Top