Honda D Series Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
So im on my way to the bank last night, finish up and head home. On my way there I get pulled over. No tailights...um ok...turn the car off,chek my fuses, tailight fuse was blown. Replace it, tailights dont come back on, and heater wont work anymore...but my brake lights work and back up lights work. Pull every fuse and check one by one, none are blown. Cops decide to give me a safety check(quebec cops are THE WORST buy the way) So i need to call a tow truck to get home...80 bucks out the window.

Get home and start inspecting, press the brake pedal and blow its fuse(they worked fine 15 mins ago), replace it,many times, and it just keeps blowing its fuse, but all others are intact.

Been reading up since then, could be many things

-Running light relay, but would this cause the heater to stop(wich i strongly doubt)
-Multiplex unit( usually not to hard to find but hopefully not the problem)
-And the dreaded shorting wire somewhere in the cars wiring(be it an open in the circuit or a wire grounding somewhere this is never fun to locate:(

But would a defective relay cause fuses to blow?

Anyone got any ideas cause bringing it to a garage is definetly not an option for most of us, me included.
 

·
ministry of mayhem!
93 honda integra
Joined
·
5,673 Posts
had a situation like that a while ago, happened to be a short at the vanity light (hatch area). one cable was grounding against the metal.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Well the running light relay was completely cooked so theres one problem fixed. Now it just keeps burning the rear light fuse so im thinkin its a short for sure. And yes its a hatch. Still cant figure out why the heater was affected blower was affected.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
So it was a short as far as the lights go, drivers side tailight had a broken wire touching the body. So my lights work once again. Now to find out why the heater isnt blowing any air. I hooked it on the battery so i know it works but if i use its plug it wont. any ideas abouit that?
 
1 - 6 of 6 Posts
Top