Honda D Series Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter · #1 ·
hey guys...

well today i went to put in a new cluster i got for my car .. put it in and went for a drive ...

i have a D15b7 ... and the redline from what ive heard is 6500 rpm

so when i was driving the tach went all wacky and was jumping everywhere and the car was kinda sputtering... then it turned off ... it happened a few times ..all over 4000 rmp ..and i redlined it once .

after that i went to drive it home ... 3000rmp (regular driving) and it did it again... and then when i came to stop it was idleing below 1000 rmp

and then it turned off and wouldnt start .. and now its sitting a few blocks from my house

need help guys please .. this is my DD .. so anything is apreciated .

-thanks-
 

·
Registered
Joined
·
119 Posts
if you have old cluster maybe put it back in to get the car home.
i know that i fried a cluster in my volvo once and it created problems with the idle. check all your fuses 1st to make sure you didnt blow something installing the new cluster.
is the new cluster a repacement, or one from a diff model?
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #3 ·
its one from a diffrent modle ... it from an EX D16z6 cluster ... from an automatic ...

would that have anything to do with the problem?
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #4 ·
well i got the car home ... you think its a cluster .. alot of people have been telling me the cluster would have nothing to do with what happened
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #7 ·
nothing, last thing i had done was an oil change ... and before that a clutch ... but it ran fine untill i put the cluster in .
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #9 ·
how do you check if a ground is good..and where are all the ground wires ?
 

·
Registered
92 hatchback
Joined
·
1,517 Posts
there is the two behind the lights, there is one from the head to the body, from the starter. just make sure all are tight. if that isnt it. fuel filter clogged? or fuel pump. i doubt it would be the dizzy
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #11 ·
ok cool ill go check them in the morning ... thanks man ...
 
1 - 11 of 11 Posts
Top