Honda D Series Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
so i drive a 2001 Civic DX coupe manual, two nights ago the battery light came on, gave the car a shot of gas and it turned off, up until today the light would come on until the car was revved over 3k, and would stay off for about 5 min, but now the light just stays on, the battery has been replaced. The grounds have been checked, just wondering if anyone has any ideas of what else it could be? also would an alternator from another d series (d15/16 non vtec) and if the alternators differ from auto to manual? thanks in advance
 

·
Registered
Joined
·
1,128 Posts
Best thing for you to do is have your charging system check. As far as alternator the d series are all the same except the plugs of course obd1 and obd2 plugs are different you can cut and solder it.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
we dont have autozone here. Ive been doing research and im 99% it is the alternator. the battery light was on and off through the past two days, i replaced the battery and the light stayed on and after two starts the battery was dead again. is the 01 still obd2b? because then a 99/00 alternator would fit would it not? (assuming its for a d16y7/8)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
I rebuild altetnaters for a living. Sounds like its out of brushs hence the coming and going.
i was thinking that too, at first i thought it was the battery. Then i thought it was a dead spot, now it wont charge at all. Im going to try and replace the alternator now. just need to find out if the d15/16/17 alternators are interchangeable.
 

·
Registered
Joined
·
3,314 Posts
01-05 Civic's have a COMPLETELY different alternator.

Look into alternator testing with a DVOM, I bet a diode is going out/is out and you are putting A/C voltage out.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
im just getting a new alternator, i have service records for the past four years from the prev owner, no record of a new alt being installed or purchased. If that doesnt work i dont know what it could be, the belts pretty much brand new and ive tried it with two batterys, all of the grounds are fine
 

·
Premium Member
theft repo sol
Joined
·
356 Posts
i have a 2002 and i have recently rebuilt the charging system. ok the 92-2000 alternators have an eld unit built in to the alternator. the 2001 + alternators have an eld unit located in the fuse box. this might be where your running into trouble.
 
1 - 11 of 11 Posts
Top