Honda D Series Forum banner

1 - 15 of 15 Posts

·
D-series Champ
Joined
·
1,338 Posts
Discussion Starter #1
can anyone give me any info on v12 amps. someone gave me one and i don't know the first thing about the processor.
 

·
FAMILY MEMBER #316
Joined
·
2,955 Posts
the 4 channels like to overheat.


prolly describing the year or model would be helpful since theyve been around for awhile.
 

·
Brokedick Millionaire
Joined
·
40,292 Posts
only time I've seen an Alpine amp fail was when some "DICK" was pushing his Buick Grand National.

BTW, I've had a change of hobbies.......engines and trannys have been boring on here lately.

This might give you an idea........

Whats is the box just back from inspection?



I need a towel.......



make it a mop and bucket!!!!!!!!



Already to accept 4 gauge cables.......



Not bad for a Grant :)

50x4 + 200x1 at 4 ohms

100x4 or 200x2 + 400x1 when loaded down.
 

·
Registered
91 CRX Si
Joined
·
4,454 Posts
Don't know about the V12's but I have had several Alpine amps in the past that were great. Sony ES amps are really good. Soundstream & older Precision Power stuff is good as well.
 

·
Premium Member
2005 Legacy GT
Joined
·
1,754 Posts
I have a couple of alpine amps in my car, they seem to work really well. I don't know much about the v12 series but there's gobs of information available online. Did a lot of research before building my system and I'm really happy with my amps.
 

·
Administrator
Honda
Joined
·
6,992 Posts
only time I've seen an Alpine amp fail was when some "DICK" was pushing his Buick Grand National.

BTW, I've had a change of hobbies.......engines and trannys have been boring on here lately.

This might give you an idea........

Whats is the box just back from inspection?



I need a towel.......



make it a mop and bucket!!!!!!!!



Already to accept 4 gauge cables.......



Not bad for a Grant :)

50x4 + 200x1 at 4 ohms

100x4 or 200x2 + 400x1 when loaded down.

Only 4 Gauge... Weak
 

·
D-series Champ
Joined
·
1,338 Posts
Discussion Starter #10
i'm not sure what year it was made i'll have to look at it. it's a 300 watt (i believe) mono amp with the digital screen. i've been playing with all the toys in it but the voice coil in my 10 is fried and it's impossible to tune.think i'm just gonna go get a new jl or kicker 10 tomorrow and see how it goes.
 

·
Registered
1993 civicEX
Joined
·
206 Posts
all you have to do with the amps is put a 1/2 inch spacer in the middle of the amp and its mounting location i had a ton of costomers bring their cars back from the 4ch cutting in and out so thats all i did and i have no more problems
 
1 - 15 of 15 Posts
Top