Honda D Series Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've had this car for about a year now and finally got around to doing a lot of upgrades. This vehicle has been an uphill battle the whole way from breaking bolts in the block to breaking bolts in the frame but it's been a good learning experience.

VEHICLE:
1995 Civic Hatchback DX

ENGINE:
D15B2 (using B7 parts) Y8 head
H beam rods
PM6 strengthened pistons
King bearings

Transmission:
A000 searching for B000

Miscellaneous parts:
New fuel tank
Osias 340lph fuel pump
Stock injectors until turbo
I/H/E
Solid torque mounts
Dual row aluminum radiator with fan

Gauges:
Tachometer
Wideband o2
Boost gauge

To Do list:
Run wires for vtec

It starts right up first time every time but I have a solid CEL regardless of whether it's pinned or not. I pulled the stock ECU and it looks perfectly fine, no physical evidence of failure. I'm going to burn a p28 chip to the ECU I chipped and socketed. Any other suggestions would be appreciated.
135741

135742

135743
135744
 

·
Registered
Sloppy Jalopy
Joined
·
1,029 Posts
lookin good.
what was done to strengthen the pistons?
what kid of oil clearances did the king bearings give you ,,if checked?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
The pistons are hypereutectic and heat treated and the wrist pins were cryogenically treated. They should be 3x stronger than stock and keep my compression near factory since the rods were just a little longer (134.5mm)
I just used plastigage to check the clearances and they were all within spec after torquing down. But they're the standard set.
 
1 - 3 of 3 Posts
Top