Honda D Series Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Hi guys , i've done a jdm d15b swap in my 93 sol si and here is my problem: the car won't start.
What happened? After the swap i turned the key to ACC to check the fuel lines. At this point everything was working fine (the blower inside the car ,the fuel pump, the light on my dashboard/cluster .....) . I did it 3 times (turn the key to ACC , check the fuel lines and turn off ). Then i've decided to crank the engine. I turned it and i heard a sound like a fuse that blown and nothing happened ; all the light on the cluster went off . I've checked my engine compartiment fuse box and i've found one blown fuse (yellow 20A fuse). I don't even know if that was already blown when i got the car and it was running without it. But it was the only blown one that i could see. I took a look on the fuse cover for the diagram and it says that the yellow 20A is the CONDENSATOR fuse. (please take a look at pics-sorry for the quality). My car had a AC. I took it out when swaping ( i don't want it) and all of its plug are not connected Here comes my questions:


1- Can a blown condensator fuse cut all the power?
2- Why is it blown? What mistake did i do?
3- Is there any solution? What should i do?
4- Would the fact that i took out my AC be the cause?


5- WHAT CAN I DO TO MAKE THIS CAR START - PLEASE HELP.

Also different question, can you drive without the o2 sensor? If yes , is there any problem?
 
1 - 1 of 1 Posts
Top