Honda D Series Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5,841 Posts
Discussion Starter #1
could one or two of you guys please do me a solid.

Next time you have your hood popped, could you please check out a few things to help me out.

1- rear transmission wire connector, nearly under battery. plugs into what appears a solenoid. Sources from near the starter off the main loom. Wire colors please.

2- near the firewall, towards fender side of the brake booster. see the normal big plug going to the cabin? there is another plug near it. should have spots for 12 or so pins, but only 4 actually used. Is this my secondary O2 sensor hookup? as in, is there a "patch" harness of sorts that brings those 4 wires down to a normal o2 plug?

3- I have an unused 2 pin plug that branches off the main harness under the battery. it appears to not be long enough to go anywhere.

BACKGROUND:

my 1997 civic dx automatic needed a new engine harness. I thought I had searched enough pinout diagrams to verify that a d16y8 auto harness would drop in, leaving only some useless vtec plugs. Why this route? I swapped to a d16y8 intake manifold, and this seemed like the best compromise of a new harness, that had proper sensor wire lengths to go around the new manifold config (y7 harness requires plastic loomwrap cut and re-wrap to stretch around)


Thanks guys.

Currently, the car throws 2 codes. 1 for each o2 heater circuit (primary and secondary)

gauge cluster also lights up "2" gear indicator, no matter what. it shifts everywhere just fine. light for "D4" indicator is never lit and never lights up.
 

·
Banned
Joined
·
12 Posts
could one or two of you guys please do me a solid.

Next time you have your hood popped, could you please check out a few things to help me out.

1- rear transmission wire connector, nearly under battery. plugs into what appears a solenoid. Sources from near the starter off the main loom. Wire colors please.

2- near the firewall, towards fender side of the brake booster. see the normal big plug going to the cabin? there is another plug near it. should have spots for 12 or so pins, but only 4 actually used. Is this my secondary O2 sensor hookup? as in, is there a "patch" harness of sorts that brings those 4 wires down to a normal o2 plug?

3- I have an unused 2 pin plug that branches off the main harness under the battery. it appears to not be long enough to go anywhere.

BACKGROUND:

my 1997 civic dx automatic needed a new engine harness. I thought I had searched enough pinout diagrams to verify that a d16y8 auto harness would drop in, leaving only some useless vtec plugs. Why this route? I swapped to a d16y8 intake manifold, and this seemed like the best compromise of a new harness, that had proper sensor wire lengths to go around the new manifold config (y7 harness requires plastic loomwrap cut and re-wrap to stretch around)


Thanks guys.

Currently, the car throws 2 codes. 1 for each o2 heater circuit (primary and secondary)

gauge cluster also lights up "2" gear indicator, no matter what. it shifts everywhere just fine. light for "D4" indicator is never lit and never lights up.
Ill check it out when i get home.
 

·
セックス大好&#
Joined
·
503 Posts
Any of these the plugs in question? If I can get a connector number I can help you out greatly lol







Alldata is rad.
 

·
Registered
Joined
·
5,841 Posts
Discussion Starter #4
Im browsing through a downloaded service manual.


But from your pictures, I will try to take a stab at the numbers im looking at.



under battery, immediately off loom. # c141

firewall/brake booster side main plugs #'s c101 and c136


and Im still left with where my secondary o2 plug is. I dont have one period lol. That is my biggest problem.



Id love to able to say the jackass on ebay sold me a 99-00 harness, but the distributor plugged in just fine and I dont have any other codes (wiring is move3d around a bit at the ecu on obd2b)



Thanks for the help so far guys. Im not getting defeated by this damn civic!
 

·
セックス大好&#
Joined
·
503 Posts
C141 is to the EVAP control canister vent shut valve
Looks to have light green/white and black/yellow wires



C101 and C136 is to the main harness




Doesn't show a pinout for C136



Secondary O2 plug is C125, by the exhaust manifold
 

·
Premium Member
Joined
·
5,819 Posts
Dam was hoping you would post the pinout said for the c136 plug. I know where they go but no clue as to what there for. Guessing for the auto tranny. I can't find a pinout for the b Ecu plug where those wires go to.
 

·
セックス大好&#
Joined
·
503 Posts
Give me a second, I passed it like 3 times looking for that other stuff, will update when I find it again

The B ecu plug anyways, I still haven't found a pinout for 136

Edit: Got you



I believe that's it. Alldata is so damn difficult to navigate sometimes, it's like walking around in walmart, where the aisles go, food, food, food, laundry detergent, food, food. Things aren't always where you'd expect them to be
 

·
Premium Member
Joined
·
5,819 Posts
The wires color I have on a harness don't match the wire colors in that pinout.

I have for the b plug from c136 plug

Green/black to b13

White to b16

White/red to b12

Blue to b17
 

·
セックス大好&#
Joined
·
503 Posts
In that case.....



Unless the harnesses are different between the different years and trim/body of that generation, I looked up everything I posted under a 97 model EX coupe
 

·
Registered
Joined
·
5,841 Posts
Discussion Starter #10
my head is spinning from trying to go through the servie manual.


I did find a good clean pinout of the B ecu plug for the auto.

nothing ti indicate why "2" is lit up on the dash.


I am however going to be probing some ecu wires this weekend to see if all my sensors are actually making it to the ecu.


I have a bad feeling this harness is shot. I lost ECT on the scanner, and pushing the backside of the lug underhood fixed it.


moss, I dont have a second O2 at the exhaust manifold.


I wonder if it was cut off at some point years ago and never repaired. I literally scoured the entire harness during install last weeked and found zip.
 

·
Premium Member
Joined
·
5,819 Posts
I can't remember if it's 96-98 or 99-00 where the 2nd o2 is part of the cabin harness. It could be both just different model thing. This is where Honda made it difficult. Even tho the harness is from the same year there are little differences that give us big headaches.


Try unplugging the engine harness one plug at a time to see what turns off the number 2 light might help narrow what is causing it to stay on down.
 

·
Registered
Joined
·
2 Posts
I know the is an old thread, but I was just wondering how Mattliston resolved this issue. I am having the exact same issue. I dropped a 72k mile D16Y7 from a wrecked 1998 LX automatic sedan (81 year old lady) into a 1997 LX automatic sedan. Not catching the extra plug(c136), I used the harness and ECU from the 98 in the 97. BING! CEL on, no D4, and D2 always on. I swapped out eco for the original 97 and no more CEL. Is the gear shift indicator issue related to the C136 plug. My plan is to make my own harness for that plug if I have to. I do not have a wiring scamatic for this 97 lx. any help would be much appreciated. Thanks.
 

·
Registered
Joined
·
5,841 Posts
Discussion Starter #13
I never really solved this issue.

I chalked it up to a bad engine harness, possibly some bad sensors or solenoids on the transmission, and dealt with it.

I have since then given away the car
 

·
Registered
Joined
·
2 Posts
Ok, thank you for getting back to me. I know that the 8 pin(4 wire) plug is the issue, as 3 of the wires go to "trans control" and the 4th goes to the interlock system. So it has to do with the dash wiring after it leaves the plug. I just don't have an ETM to trace where exactly they go after they leave the plug and go through the firewall. The fact that we both had the same issue kinda rules out the bad harness theory. Know anyone that has the 96-00 civic Electrical Troubleshooting Manual? The "trans control" and "interlock" was written in another forum, but no wiring info.
 

·
Registered
Joined
·
5,841 Posts
Discussion Starter #15
search for the freely available civic tech manual.

I think it was titled "ab0ve" or something similar
 

·
Registered
Joined
·
5,841 Posts
Discussion Starter #16
well, found one quickly. Seems this one is laid out very nicely

https://archive.org/details/HondaCivic19962000

Its a computer website only. I dont see a download link.

This is the SAME manual that can be found with some google searching though, in PDF form

EDIT beer vision left me unable to see the very clearly marked download options on the right side of page.

WHOOPS!
 
1 - 16 of 16 Posts
Top