Honda D Series Forum banner

1 - 12 of 12 Posts

·
Registered
Ek Hatch/09 Ruckus
Joined
·
2 Posts
Discussion Starter #1
ok, when i first crank the car up it runs good and no lights are on, but once i get a few miles down the road and the engine warms up the check engine light comes on. What do you think it could be? i was thinking it might be an 02 sensor but im not sure, just want to get some other peoples ideas
 

·
Registered
91 CRX Si
Joined
·
4,454 Posts
o2 is a common problem. Does the car stutter or stumble upon acceleration once the light is on?
 

·
Registered
08 H-D Ultra Classic
Joined
·
985 Posts
O2 sensor heater ???
 

·
Registered
91 CRX Si
Joined
·
4,454 Posts

·
Registered
del sol
Joined
·
20 Posts
could be 02 or idle air control valve or many different things more info would be great.: tune up history, miles, exact engine, mods. ect...
 

·
Registered
Joined
·
1,357 Posts
Holy crap....
Ok
1. pull the carpet in the pass side floor board back (the area were your feet go"
2.there should be a metal plate with a hole in the middle/ or plate is gone and ecu is visible
3. the ecu has a red light that flashes
4.Count how many flashes there is when its done the flashing will restart

Give us the number of flashes OR google

(90 civic ecu codes)
 

·
Registered
Ek Hatch/09 Ruckus
Joined
·
2 Posts
Discussion Starter #12
ok well that motor blow up lol so i droped a obd1 jdm d15b into it and it still does it but now its just throwing a knock sensor code and some other one i cant remember, but sometimes it does want to stutter upon acceleration at lower rpms but i was told the light weight flywheel could be doin this. and thanks for all the help guys.
 
1 - 12 of 12 Posts
Top