Trans problem or master/slave problem? - D-series.org

Go Back   D-series.org Motor Mayhem & Suspension Satisfaction Transmission alley

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-08-2019, 03:21 PM   #1 (permalink)
n00b
 
iTrader: (0)
Join Date: Aug 2018
Posts: 12
Rep Power: 0 Sol-Yang is nobody
iTrader Score: 0 reviews
Default Trans problem or master/slave problem?

Was driving home today in 5th gear, del sol d16z6, decided to downshift but as soon as my foot hit the clutch pedal it would not depress. It felt jammed. I've done some research and have maybe narrowed it down but like some Input. Could the clutch pedal rod be jammed/ master cyclinder? Could it be the clutch pedal springs? Or could it be the TO bearing? Has anyone ever ran Into this problem?
Sol-Yang is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 11:16 PM. | Welcome to Forum, please register to access all of our features.