Can anyone help me with my JDM d15b engine - D-series.org

Go Back   D-series.org Everything Else New Member Introductions

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-25-2015, 06:37 AM   #1 (permalink)
n00b
 
iTrader: (0)
Join Date: Oct 2015
Posts: 0
Rep Power: 0 nadnaden is nobody
iTrader Score: 0 reviews
Default Can anyone help me with my JDM d15b engine

I bought a honda civic which has a d15b vtec on it (not sure which kind), after sending it to a mechanic which I am not familiar of, the car started to run like crap. As of now I cannot get a hold of this mechanic, he doesn't reply to my messages and I just found out that his shop closed down and his whereabouts are unknown.

1st, the car ran fine, no problems with it, but after crashing it I sent it to a mechanic to fix the needed parts to fix. I checked and tested the engine before and after the crash and it was the same as I've bought it. No damages were taken in by the engine.

2nd, After getting it from the mechanic the car runs rich, I smell gasoline,the idle sounds like crap. checked the spark plugs and they were black as hell, replaced the plugs and after some testing, it went black again.Whenever I stop in traffic the engine also stops(full gas in the tank). I sent it back to the mechanic and he said it was a wrong tune of the computer box(p07-chipped). so I researched a bit and order a chipped p08 box from him.

3rd, I don't know what the F happened, but he gave me a p06-chipped box and gave reasons that p06 is better( IDK if this is true),I cannot complain, Im just a 16yr old teenager and he was an old guy, I just cannot bring myself to get mad at him since I'm just a child with few experiences with cars. The car runs, the engine doesn't stop anymore when I also stop BUT when the engine gets at working temperature, when I shift and this occurs regularly at high revs when I shift, I step on the gas, no response from the engine at all. I researched a little bit and discovered that my d15b has aftermarket injectors(not sure what size) after knowing this I squeezed the fuel return line a little bit and tested it. It now runs rich and the idle sounds like crap but the response is good(no more stalling)-I think I need an adjustable fuel pressure regulator.

4th, After the 3rd step I went to another mechanic to ask what do I do and have it checked. We discovered that the 4th cylinder is not firing, this pissed me off. Compression tested it. the other 3 cylinders are around 130psi(don't know if it's still good) and the 4th @ 30psi(wet and dry test, the compression did not increase). they said I have a leaking valve. note-this is still a week after sending it from the 1st mechanic

All in all a mechanic fucked me up and that I just have little money since Im just a teenager, can anyone give me help/tips what should I do with this engine at minimum cost. This is the summary of the problems of my engine:
>4th cylinder not firing
>engine is stalling
>Computer box
>aftermarket injectors

Note- I just discovered that this mechanic has a bad name in our area, he cheats his customers,etc. I shouldv'e background checked him before giving it to him in the first place.
nadnaden is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 12:20 AM. | Welcome to Forum, please register to access all of our features.