Tach not working - D-series.org

Go Back   D-series.org D-series Knowledge Factory General Tech

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-09-2018, 03:30 AM   #1 (permalink)
JKM
n00b
 
iTrader: (0)
Join Date: Apr 2016
Location: JHB, South Africa
Posts: 7
Rep Power: 0 JKM is nobody
iTrader Score: 0 reviews
Default Tach not working

Hello there everyone.
First post on here, joined in 2016. I feel like I should introduce myself, but don't want to derail my own tech question .

I've got a 1996 ek hatch that was running a boosted D16y9 non vtec motor. (south african car)
The motor blew up so I bought a D15z motor, it's got a vtec head on stamped P08-6, it came with the harnass and ECU.
To get to my question, neither the tacho or speedo works since the swap. I think it's got something to do with the dizzy on the motor and the wiring from the car. I hope someone might be able to help me on this.
I'm using the cars original ecu with a piggy back chip controlling vtec, the ecu that came with the motor also gave the same problem plus when driving it would rev up but wouldn't speed up (ie. limp)

I'm really lost on what it could be, it went from a non vtec boosted car with a home made harness to a n/a vtec. So it could be a number of things.
I'm trying to attach images, have a tough time
Attached Thumbnails
Click image for larger version

Name:	Plug on car.jpg
Views:	12
Size:	825.1 KB
ID:	123417  
JKM is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-09-2018, 03:42 AM   #2 (permalink)
JKM
n00b
 
iTrader: (0)
Join Date: Apr 2016
Location: JHB, South Africa
Posts: 7
Rep Power: 0 JKM is nobody
iTrader Score: 0 reviews
Default

Ok, only 1 pic uploaded.
The ecu in the car: 37820-P2C-Y01 137-149231 DR
Ecu that came with motor: 37820-P2K2-V01 154-106515 D4

The dizzy has a 7 pin plug, I've got a spare Dizzy from my old motor that has a 10 pin plug.
JKM is offline   Reply With Quote Quick reply to this message
Old 01-09-2018, 04:47 AM   #3 (permalink)
\/Your Mom Was Here\/
 
BeerDrinkin's Avatar
 
iTrader: (11)
Join Date: Feb 2010
Location: South of Nashville
Posts: 4,825
Rep Power: 54 BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !
BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !BeerDrinkin is on a level you can only DREAM about! ! !
iTrader Score: 11 reviews
Default

When you swapped the motor did you change the wiring around anywhere???
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2005 Civic EX Sedan (ES2)



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

You will be missed but not forgotten.

Quote:
I actually jerk off to my rep points, neg rep makes me thumb my bung, what now brown cow? I finished twice.
BeerDrinkin is offline   Reply With Quote Quick reply to this message
Old 01-09-2018, 06:08 AM   #4 (permalink)
JKM
n00b
 
iTrader: (0)
Join Date: Apr 2016
Location: JHB, South Africa
Posts: 7
Rep Power: 0 JKM is nobody
iTrader Score: 0 reviews
Default

Howzit BeerDrinkin,
Yes I did (not myself, auto elec), I got a wiring loom with the motor and that was put in. the wiring loom that was in was hacked to death, the new loom was OEM. I got the ECU with the motor but that didn't work so I put back my ECU that I had. But even with the ECU that came with the motor this problem existed.
The D16y9 used a 10pin dizzy and this D15z has a 7 pin.
I know there's 8 & 10 pin Dizzy's, haven't seen this 7 pin before.
I'm attaching a pic,
Attached Thumbnails
Click image for larger version

Name:	Dizzy on car.jpg
Views:	11
Size:	196.4 KB
ID:	123425  
JKM is offline   Reply With Quote Quick reply to this message
Old 01-09-2018, 06:11 AM   #5 (permalink)
JKM
n00b
 
iTrader: (0)
Join Date: Apr 2016
Location: JHB, South Africa
Posts: 7
Rep Power: 0 JKM is nobody
iTrader Score: 0 reviews
Default

oh BTW, thanks for the reply Bud.... weiser.


That's right... you saw what I did there
JKM is offline   Reply With Quote Quick reply to this message
Old 01-09-2018, 09:23 AM   #6 (permalink)
D-series G0D
 
2jzdreamin's Avatar
 
iTrader: (49)
Join Date: Aug 2009
Location: C.T.
Posts: 5,819
Rep Power: 30 2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !
2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !
iTrader Score: 49 reviews
Default

I would check fuses and grounds for the vss and tach. We don’t have that distributor here in the USA. I don’t know the wire colors for that distributor usually the blue wire is for tach,there could be a brake in the wire.
__________________
MY BUILD THREAD WITH WIRE AND BRAKE LINE TUCK
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


PM me for obd1,obd2 & k-series tucked harnesses

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

all so do vtec sub-harness

MAGIC-WIRES FOR YOUR ENGINE HARNESS NEEDS

instagram @magicman9won4
2jzdreamin is offline   Reply With Quote Quick reply to this message
Old 01-09-2018, 12:25 PM   #7 (permalink)
JKM
n00b
 
iTrader: (0)
Join Date: Apr 2016
Location: JHB, South Africa
Posts: 7
Rep Power: 0 JKM is nobody
iTrader Score: 0 reviews
Default

Thanks 2jzdreamin.
Where would the grounds be located for the Tach and VSS?
VSS would explain the speedo not working, i'm using my old s40 gearbox that I had, it worked then.
I tried to google that 7 pin dizzy no luck. I also don't see either of those ecu part numbers on a list I saw here on D-series. I think I need to go get a can of contact spray tomorrow and a multi meter. I'm also getting a faint battery light, even though I put in a new battery today.
JKM is offline   Reply With Quote Quick reply to this message
Old 01-09-2018, 01:40 PM   #8 (permalink)
D-series G0D
 
2jzdreamin's Avatar
 
iTrader: (49)
Join Date: Aug 2009
Location: C.T.
Posts: 5,819
Rep Power: 30 2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !
2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !2jzdreamin is on a level you can only DREAM about! ! !
iTrader Score: 49 reviews
Default

For the vss looking at the plug from where the wires go in with the release tab facing up black= ground and is on the left. Middle is 12 volt switches power and right is signal.vss could have a bad connection or a broken wire in the harness.
__________________
MY BUILD THREAD WITH WIRE AND BRAKE LINE TUCK
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


PM me for obd1,obd2 & k-series tucked harnesses

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

all so do vtec sub-harness

MAGIC-WIRES FOR YOUR ENGINE HARNESS NEEDS

instagram @magicman9won4
2jzdreamin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 12:23 PM. | Welcome to Forum, please register to access all of our features.