Injector/Fuel Pump woes? - D-series.org

Go Back   D-series.org Motor Mayhem & Suspension Satisfaction Forced Induction

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-11-2016, 01:01 PM   #1 (permalink)
n00b
 
iTrader: (0)
Join Date: May 2012
Posts: 28
Rep Power: 0 hoimmaslapyou is nobody
iTrader Score: 0 reviews
Default Injector/Fuel Pump woes?

Thought it would be a while before I came back with troubles..

Long story short, 94 Civix DX, stock d16z6, smallish turbo, adjustable FPR, DSM black tops and box, Walbro 255, bkr7e's and factory ignition system (wires, distributor, etc) tuned on ECTune.

The rundown -- was driving home today, car is at about a 1/4 tank of 93, let off the gas while braking because it seems to have developed a habit of puffing smoke during decel while in gear, didn't do it when it was freshly tuned; and the car died. Immediately started it back up, proceeded to run fine and drive as usual. About 10 minutes later I was accelerating and the car died completely. Wouldn't start back up, though I could hear fuel pump priming. After several attempts at starting the car, it finally fired and managed to get me home, all while running as if nothing had happened.

Haven't torn into it to try to diagnose it yet, came here to see if anybody has any recommendations as to what I ought to look for? My Wideband never give me any strange readings during running and the car never threw a CEL. It cranks fine, goes to start and it's like someone has just suffocated it, doesn't even try to idle. I will also note that when its hot (I live in Florida) and the car has run for 20 minutes or so I can hear the fuel pump whining hard, and in some instances while my blinkers are being used I can hear it fluctuating with the blinkers. Sometimes it will fluctuate at a normal idle.

Ideas?
hoimmaslapyou is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-11-2016, 03:46 PM   #2 (permalink)
n00b
 
iTrader: (0)
Join Date: May 2012
Posts: 28
Rep Power: 0 hoimmaslapyou is nobody
iTrader Score: 0 reviews
Default

New symptom, fuel pump primes only when the key is turned as if you were starting the car, but not accessory on, CEL and ABS lights aren't working on accessory on either, only when the key is turned to actual start. Guessing this is indeed ignition related.
hoimmaslapyou is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 06:15 AM   #3 (permalink)
n00b
 
david_2oosx's Avatar
 
iTrader: (0)
Join Date: Jul 2014
Posts: 14
Rep Power: 0 david_2oosx is nobody
iTrader Score: 0 reviews
Default

Had simular problems on my ek4, changed igniton switch and there was no more problems so i would start there.
david_2oosx is offline   Reply With Quote Quick reply to this message
 
Old 04-12-2016, 07:05 AM   #4 (permalink)
n00b
 
iTrader: (0)
Join Date: May 2012
Posts: 28
Rep Power: 0 hoimmaslapyou is nobody
iTrader Score: 0 reviews
Default

Did you change the full ignition/locking mechanism or just the electronics?
hoimmaslapyou is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 11:06 AM   #5 (permalink)
D-series PIMP
 
HiProfile's Avatar
 
iTrader: (9)
Join Date: Sep 2005
Location: SoWis
Posts: 1,225
Rep Power: 24 HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!
HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!HiProfile is the fucking MAN!!!!
iTrader Score: 9 reviews
Default

First look at the ignition switch, then maybe the main relay. EG/EK are old enough where BOTH parts are starting to fail, but nobody ever believes it til they replace them.

To explain why it would prime on "start" but not "on", they use different contacts to power different main relay pins. "Start" runs the main relay directly, while "on" allows the ECU to activate the main relay. If one or both of the ignition switch contacts are bad, or either of the main relay pins/wires are bad, it will not prime in either/both key positions.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HiProfile is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 01:28 PM   #6 (permalink)
n00b
 
iTrader: (0)
Join Date: May 2012
Posts: 28
Rep Power: 0 hoimmaslapyou is nobody
iTrader Score: 0 reviews
Default

Okay, cool. I thought it odd that all of a sudden it wasn't priming like it normally did. I believe I've got an old main relay I pulled that was still functioning (preventative measures I take when I buy any type of Honda lol) that I'll give a whirl. Certainly cheaper than changing out the ignition switch.
hoimmaslapyou is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 01:36 PM   #7 (permalink)
D-series soldier
 
robgoof's Avatar
 
iTrader: (3)
Join Date: May 2014
Location: and maple syrup ,Eh
Posts: 756
Rep Power: 17 robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!
robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!
iTrader Score: 3 reviews
Default

I had a similar problem ,no pump prime or dash lights in run position and occasional leave you on the side of the road .

the ignition switch contacts had worn away ..
robgoof is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 02:46 PM   #8 (permalink)
D-series G0D
 
mattliston's Avatar
 
iTrader: (10)
Join Date: Apr 2009
Location: La Crosse,WI
Posts: 5,771
Rep Power: 32 mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !
mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !
iTrader Score: 10 reviews
Default

easy way to tell if ignition wiring.

turn blinker (not hazards) on left or right. if it dies with car, its ignition wiring.


Did this on my car, solved hot stalls and stalls over bumpy roads. partially holding key towards starter position kept it running

pop sparkplugs out and check them over
__________________

2003 Hyundai Sonata GLS 2.7 Delta 197k
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1998 Cadillac Seville SLS just broke 100k
2001 civic LX coupe MTX 199k
Sometimes, the difficult path is the easiest path
D/B/F/H/K compression questions?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Build what you have!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

mattliston is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 03:56 PM   #9 (permalink)
n00b
 
iTrader: (0)
Join Date: May 2012
Posts: 28
Rep Power: 0 hoimmaslapyou is nobody
iTrader Score: 0 reviews
Default

Thanks guys, gonna try and cram my big ass up under the dash to just confirm its the switch, having trouble finding the 7 pin connector that goes to the fuse block.
hoimmaslapyou is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 04:01 PM   #10 (permalink)
BATSLOMAN GIVES 0 FUCKS
 
slo_eg8's Avatar
 
iTrader: (28)
Join Date: Mar 2009
Location: TAMPA FLORIDA
Posts: 3,854
Rep Power: 50 slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !
slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !
iTrader Score: 28 reviews
Send a message via AIM to slo_eg8
Default

google ftmfw

__________________
turbo d16z6
.42/.48 garrett
je pistons, eagle rods, y7 lsd trans w/4.3fd
koni yellow/gc coils
uber rare eg6 optional snowflakes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

new 95 ej1.
slo_eg8 is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 04:06 PM   #11 (permalink)
n00b
 
iTrader: (0)
Join Date: May 2012
Posts: 28
Rep Power: 0 hoimmaslapyou is nobody
iTrader Score: 0 reviews
Default

Yea I identified the 5 pin.. Not sure which one of those are meant to be the 7 I'm supposed to pull to check resistance.
hoimmaslapyou is offline   Reply With Quote Quick reply to this message
Old 04-12-2016, 04:27 PM   #12 (permalink)
D-series G0D
 
mattliston's Avatar
 
iTrader: (10)
Join Date: Apr 2009
Location: La Crosse,WI
Posts: 5,771
Rep Power: 32 mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !
mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !mattliston is on a level you can only DREAM about! ! !
iTrader Score: 10 reviews
Default

pull the bottom steering cover off and look at back of ignition switch. follow wiring to plug.

unplug. do the test for continuity between key positions. if it doesnt work, wiggle key around. if it then works fine, hit up ebay.
__________________

2003 Hyundai Sonata GLS 2.7 Delta 197k
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1998 Cadillac Seville SLS just broke 100k
2001 civic LX coupe MTX 199k
Sometimes, the difficult path is the easiest path
D/B/F/H/K compression questions?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Build what you have!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

mattliston is offline   Reply With Quote Quick reply to this message
Old 04-14-2016, 09:04 AM   #13 (permalink)
n00b
 
iTrader: (0)
Join Date: May 2012
Posts: 28
Rep Power: 0 hoimmaslapyou is nobody
iTrader Score: 0 reviews
Default

Couldn't find 7 pin connector because zip ties and electrical tape, SMFH. Antique car alarm wiring had it hidden.

Checked continuity and wouldn't you know it? Switch is bad. Got one coming asap. Thanks again folks.
hoimmaslapyou is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 01:36 AM. | Welcome to Forum, please register to access all of our features.