Chasing CEL's...frankenstein car - D-series.org

Go Back   D-series.org Motor Mayhem & Suspension Satisfaction Engine Management

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-27-2018, 04:53 PM   #1 (permalink)
n00b
 
iTrader: (0)
Join Date: Dec 2018
Location: Phoenix, AZ
Posts: 1
Rep Power: 0 mikelekan35 is nobody
iTrader Score: 0 reviews
Default Chasing CEL's...frankenstein car

Hey Guys! New to the forums because Ive searched all over d-series.org and cant find anything. My situation is very specific.
Recently bought a 99 Ek Coupe with a D16Y8 in it. When I purchased the car it had the motor half taken out of it. Half of the motor mounts were off, harness was disconnected. The previous owner, lets call him Tim, had told me that he had sold it to some kid who swapped it from an auto to a manual and then it got impounded and Tim received the car back after it was impounded. I purchased the car knowing it was going to be a lot of work to put together. I got the motor mounts back in and reconnected the harness so it would be a running car. Well i fired it up and it was idling funky. Through further research I found that the kid who tranny swapped it did not do the IACV fix. So luckily i had a Intake Manifold from a 2000 D16Y8 with a known working IACV. I repinned the harness and changed the 3 wire plug to a 2 wire plug. Fired it up, no change in the idle. Chased a vacuum leak for a while and it turns out the Cylinder Head on this 99 Civic was from a 96 Civic so it had no Air Injection like the 99-00. Well drilled and tapped the intake manifold to plug up the Air injection holes. Turned it on, no change. Went and got the codes checked on it and I had misfires in all 4 cylinders. Long story short there was no belt tensioner on the timing belt and it had jumped a tooth. Re did timing belt and fired it up and it idled like a dream. Got the codes checked one more time. I had a code for secondary 02 sensor and knock sensor. No big deal I ordered a new 02 sensor and had a working knock sensor on a spare D16Y8. Put them in, 02 sensor code went away but knock sensor code was there. But the car was running great. Over the past few days the car is bucking at COMPLETE RANDOM times. Every once in a while ill start it up and itll run great. And then ill go to the store or whatever, come back out and start it up and it acts funky. My normal idle is around 800 and when its acting weird itll idle up to 1300 and bounce like its on a rev limiter. If I drive it when its doing that, thats when it starts bucking. Codes now say IACV and Knock Sensor. Okay whatever. Im on my third knock sensor and the code wont go away. I check if its the IACV by having the motor on while I unplug and plug it back in to see if it makes a difference. When its plugged in itll idle at 1300 and bounce like i said. When i unplug it, it idles at around 800 normal idle but if i give it gas it bounces at 1300 just like it did when it was plugged in. Again this is not how it is at every start up or every time i drive it is completely random. At colder temps if I turn on the car with the IACV unplugged it almost dies. Im completely dumbfounded and have been dealing with this for months. Not sure what to do. Any help is appreciated.
mikelekan35 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
auto to manual, d16y8, iacv, idle issues, knock sensor

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 02:36 PM. | Welcome to Forum, please register to access all of our features.