d15b7 idle problem - D-series.org

Go Back   D-series.org Motor Mayhem & Suspension Satisfaction Engine Management

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-17-2016, 09:22 AM   #1 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Question d15b7 idle problem

ever since i purchased my eh2 (canada), the idle rpm was off spec at not even 200 rpm, sometimes seemed almost 0 rpm. at first it didnt bother me as the engine was running ok. recently i did a water pump change and now the engine keeps sputtering at idle and still really low rpm. not only that but i clearly feel less power being output.

moreover, i performed an idle speed adjustment by unplugging eacv, tightening the idle screw and reseting ecu, but engine still idles at almost 0 rpm. also when i unplugged the eacv and turned engine on, as indicated in honda manual, the engine would die and not idle at a certain tpm as specified in honda manual. this could be a hint of the source problem maybe.

i am pretty sure my timing is off since im getting less power, but what about the sputtering and bad idle speed?

also i checked every spark plug with a timing light and they are ok, however the engine sputters so i could clearly see the timing light was not blinking at a constant rate, it was an off/broken beat.

maybe air filter? but then again why would the idling rpm not change after i tightened the idle screw and reset the ecu? without the eacv plugged the engine would die without pressing on accelerator (on neutral transmission position). weird stuff going on... anyone has an idea?
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-17-2016, 10:45 AM   #2 (permalink)
D-series G0D
 
xile6's Avatar
 
iTrader: (9)
Join Date: Apr 2007
Location: Tx
Posts: 6,365
Rep Power: 25 xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!
xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!
iTrader Score: 9 reviews
Default

Idle doesnt effect power output...so with that said you probably didnt put the timing back correctly.

Also the frist dash on the rpm gauge us 500 not 0.
And the car can never idle lower then 400 rpms without stalling out.
__________________
Rep when need.
I also have shopkey if you need diagrams PM me. I am a Wiring Master.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
. RIP

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
xile6 is offline   Reply With Quote Quick reply to this message
Old 08-17-2016, 12:33 PM   #3 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

ok thanks for the info, also i got a new update: i loosened the idle screw and now the engine wont die without the eacv. so my guess is that the idle setting is the culprit (screw was too tight in there). the problem now is that the screw was a pain in the a** to turn and from trying and trying to turn i stripped that b*tch off and now i think i need to remove the TB and use screw extractor. lol what a fkn b*tch that screw is the slot is so soft
eh2d15b7 is offline   Reply With Quote Quick reply to this message
 
Old 08-17-2016, 12:38 PM   #4 (permalink)
D-series soldier
 
robgoof's Avatar
 
iTrader: (3)
Join Date: May 2014
Location: and maple syrup ,Eh
Posts: 756
Rep Power: 17 robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!
robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!robgoof is the fucking MAN!!!!
iTrader Score: 3 reviews
Default

engines cannot idle at ,( sometimes seemed almost 0 rpm.)and still sound "ok"

if it is low on power after wawa pump change then you probably installled the cam off a tooth .
robgoof is offline   Reply With Quote Quick reply to this message
Old 08-17-2016, 04:28 PM   #5 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

update: finally after forcing like a bull and stripping the idle adjusting screw, i took off throttle body, this screw is a fkn b*tch for real. here some pics

how should i remove that?
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	120
Size:	436.1 KB
ID:	112426  
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 08-17-2016, 04:38 PM   #6 (permalink)
BATSLOMAN GIVES 0 FUCKS
 
slo_eg8's Avatar
 
iTrader: (28)
Join Date: Mar 2009
Location: TAMPA FLORIDA
Posts: 3,854
Rep Power: 50 slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !
slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !
iTrader Score: 28 reviews
Send a message via AIM to slo_eg8
Default

get another throttle body
__________________
turbo d16z6
.42/.48 garrett
je pistons, eagle rods, y7 lsd trans w/4.3fd
koni yellow/gc coils
uber rare eg6 optional snowflakes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

new 95 ej1.
slo_eg8 is offline   Reply With Quote Quick reply to this message
Old 08-17-2016, 05:55 PM   #7 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

Quote:
Originally Posted by slo_eg8 View Post
get another throttle body

thought about that but after drilling, banging and tweaking in out, i finally got that adjusting screw out lol fkn hell that was tough what a b*tch that screw is im lubing the sh*t outta that screw when im putting a new one back in like im greasing it so it unscrews like butter.

here pics of the b*tch all stripped up

anyways im performing another idle adjust tomorrow ill let yall know how it goes

thanks for the support everyone
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	87
Size:	436.9 KB
ID:	112434  
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 08-18-2016, 09:40 AM   #8 (permalink)
D-series G0D
 
xile6's Avatar
 
iTrader: (9)
Join Date: Apr 2007
Location: Tx
Posts: 6,365
Rep Power: 25 xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!
xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!xile6 is the fucking MAN!!!!
iTrader Score: 9 reviews
Default

Oem screw has an oring and lockthread on it so the screw doesnt vibe itself loose or tight.

I still think your timing is off. You didnt touch idle before the waterpump so why touch it after.
__________________
Rep when need.
I also have shopkey if you need diagrams PM me. I am a Wiring Master.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
. RIP

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
xile6 is offline   Reply With Quote Quick reply to this message
Old 08-20-2016, 03:47 PM   #9 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

Quote:
Originally Posted by xile6 View Post
Oem screw has an oring and lockthread on it so the screw doesnt vibe itself loose or tight.

I still think your timing is off. You didnt touch idle before the waterpump so why touch it after.
i touched idle because it was low even before i replaced the water pump. now i got it to 1.2k rpm at idle because when i took the tb out the tb gasket ripped appart so there is vacuum leak right in the fitv air bypass section of the tb. which is why my idle is high now - too much air getting in throught that ripped tb gasket. i thought of using liquid gasket instead of spending $25 (shipping included) on a new tb gasket, or maybe get one from scrap yard but not sure about swaping in a used tb gasket... what do you think?


as for my timing, yes i know its probably off but before i want to fix the idle and also will change the air filter. the one i have now is from scrap yard lmao
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 08-20-2016, 03:53 PM   #10 (permalink)
BATSLOMAN GIVES 0 FUCKS
 
slo_eg8's Avatar
 
iTrader: (28)
Join Date: Mar 2009
Location: TAMPA FLORIDA
Posts: 3,854
Rep Power: 50 slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !
slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !slo_eg8 is on a level you can only DREAM about! ! !
iTrader Score: 28 reviews
Send a message via AIM to slo_eg8
Default

find some gasket maker at your local parts store. comes in sheets
__________________
turbo d16z6
.42/.48 garrett
je pistons, eagle rods, y7 lsd trans w/4.3fd
koni yellow/gc coils
uber rare eg6 optional snowflakes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

new 95 ej1.
slo_eg8 is offline   Reply With Quote Quick reply to this message
Old 08-21-2016, 07:21 AM   #11 (permalink)
wise in the ways of the D
 
Whoshot's Avatar
 
iTrader: (4)
Join Date: May 2011
Location: Awesome World
Posts: 1,817
Rep Power: 44 Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !
Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !Whoshot is on a level you can only DREAM about! ! !
iTrader Score: 4 reviews
Default

Or some gasket gel, form a seal or what not, I use it on my water neck to my radiator. Apply a little to both sides, let it get tacky and screw her down. Wouldnt trust a high pressure spot with out a proper gasket there and the sealant as just a corner leak protector......rambling on here sorry.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Quote:
They stop laughing at your piece of shit when they can only see it through your dust.
R.I.P. - NN4S
R.I.P. - Cali Noob

You guys are gone but never forgotten, we live each day to the fullest for you, who cannot see the new day we often forget is amazing.

xbox gamer tag: angeloah
Whoshot is offline   Reply With Quote Quick reply to this message
Old 08-24-2016, 10:12 AM   #12 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

update: hey guys thank you all for the input it really helps!

Here is what i did the past few days:

-clean TB
-replaced tb gasket
-replaced adjust screw
-tried to adjust idle with steps from manual

after doing so the rpm still low at 500 or so even with adjust screw completely off.

next i took off eacv (iacv) and cleaned it. also cleaned intake ports of eacv/iacv.

still low rpm at 500. my guess is the eacv/iacv is bad. i know it is receiving signal from ecu because when i turn on electrical load such as headlights or heat fan, the engine rpm tries to keep up but cant and goes down a little. then i turn those off and it goes back up a bit. so the eacv/iacv is receiving ecu signal(current) but it seems it cant really open fully.

so my verdict for low idling is bad eacv/iacv

what do you guys think?
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 08-24-2016, 10:47 AM   #13 (permalink)
wise in the ways of the D
 
AutoXCivic's Avatar
 
iTrader: (19)
Join Date: Sep 2007
Location: Eugene, Oregon
Posts: 1,754
Rep Power: 25 AutoXCivic Still a JDM Star....
AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....
iTrader Score: 19 reviews
Send a message via AIM to AutoXCivic Send a message via MSN to AutoXCivic Send a message via Yahoo to AutoXCivic
Default

To test IACV. Pull the intake off and let the car idle and get up to temp. Plug TB opening ... does the car die?

Yes - IACV good
No - IACV bad

If IACV good ... next I'd check the FITV. On the underside of the TB. Pull that off and open it up. Sometimes it comes loose and you have to stick a flat head in there and tighten it back down. I know that was the source of some idle issues on my B7 ... mostly hunting for me but may be part of your issue.
__________________
Straight lines are for sissies.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<--- Stolen
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<--- Sold.

Quote:
barrel roll in airplane > barrel roll in nsx
AutoXCivic is offline   Reply With Quote Quick reply to this message
Old 08-25-2016, 06:59 AM   #14 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

will try some other eacv, get back to you asap
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 civic cx cdm (eh2)
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 08-30-2016, 04:49 PM   #15 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

update: got another eacv from scrap yard but still same thing so i dont think eacv is culprit afer all....

today replaced pcv valve (old one was done pretty much)

helped a little to get idle rpm up a bit

going to set timing right soon and then completely flush and bleed cooling system as well as engine oil with engine oil flusher (and new oil filter of course)... will possibly clean oil breather chamber... what else can i do? clean fitv valve? seen people suggest this but manual says to not do anything to fitv as it has been adjusted to spec.

anyways i doubt fitv is culprit for low idle as fitv is only there to high rev engine during start but then shuts off after warmed engine. and it is doing this as it is supposed to. my engine at start revs at about 1200 then a min later goes down to 650 now with new pcv, oh and by the way i took the adjust screw off completely now. this is weird that even with the screw fully off it still kinda low 650 rpm... and yes there is vacuum going in through the screw hole... i just not sure why even with it off the idle is low. must be something related to the pcv system. i think there is something clogged between the pcv and breater chamber. i think the connector from breater chamber to pcv hose must be clogged. will clean it after timing engine... anyways, suggestions anyone ?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 civic cx cdm (eh2)
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 08-31-2016, 07:44 AM   #16 (permalink)
wise in the ways of the D
 
AutoXCivic's Avatar
 
iTrader: (19)
Join Date: Sep 2007
Location: Eugene, Oregon
Posts: 1,754
Rep Power: 25 AutoXCivic Still a JDM Star....
AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....AutoXCivic Still a JDM Star....
iTrader Score: 19 reviews
Send a message via AIM to AutoXCivic Send a message via MSN to AutoXCivic Send a message via Yahoo to AutoXCivic
Default

FITV doesn't need cleaning ... there's a part that comes loose over time. You have to stick a flat head in there an tighten it back down.
__________________
Straight lines are for sissies.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<--- Stolen
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<--- Sold.

Quote:
barrel roll in airplane > barrel roll in nsx
AutoXCivic is offline   Reply With Quote Quick reply to this message
Old 09-06-2016, 04:37 PM   #17 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

update: hi guys, i finally got my timing right and fortunately the sputtering stopped! my timing was so off like 35-40 degrees btdc lol... anyways, my idle still low. got new pcv at local parts store... still no go... i checked all vacuum lines seems ok. fitv seems ok. eacv is ok i swapped it with working one... right now im suspecting the oxygen sensor. acceleration is bad on first gear and i recently got a cel code number 1 which is oxygen sensor. i purchased. new one from bosch for $60. ill replace it this week end and let ya'll know how it goes.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 civic cx cdm (eh2)
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 09-12-2016, 05:25 PM   #18 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

update: i replaced the oxygen sensor, i finally replaced it with a Denso and not a Bosch, because i heard Densos are better for jdms... anyways i got the bosch still maybe ill try it out someday. ok so the engine cel never came back with the new denso o2 sensor BUT the f*cking idle still low! wtf! so now im suspecting the fuel filter. because i looked up and a bad acceleration along a low idle could be caused by a clogged fuel filter... my eg is pretty stock and all those things im replacing are oem from 93 lol. even the air filter i replaced and was oem... last step is fuel filter hope it works... got one from FRAM i will maybe replace it tomorrow... oh by the way ive been sea foaming my car the past 2 weeks, did it again today... lots of smoke lol. also changed spark plugs today and did a compression test. 170-180 across all pistons f*ck yeah. now i can only hope that a fuel filter change will get the idle and acceleration right. will send update soon.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 civic cx cdm (eh2)
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 09-13-2016, 01:32 PM   #19 (permalink)
Member
 
eh2d15b7's Avatar
 
iTrader: (0)
Join Date: May 2016
Posts: 49
Rep Power: 0 eh2d15b7 is nobody
iTrader Score: 0 reviews
Default

update: new fuel filter installed... still low idle - tried adjusting again and no go. i have to keep the adjusting screw completely off for it to idle at decent 600-800 rpm. but sometimes at a stop it will even go down to 500. i took it for a ride and the hesitation when accelerating is still there. now im suspecting my injectors to be bad or clogged. what do you guys think ? this seems to be a never ending problem lol
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

93 civic cx cdm (eh2)
eh2d15b7 is offline   Reply With Quote Quick reply to this message
Old 09-13-2016, 03:14 PM   #20 (permalink)
D-series lover
 
evotec1's Avatar
 
iTrader: (0)
Join Date: Jun 2007
Posts: 285
Rep Power: 13 evotec1 will become famous soon enoughevotec1 will become famous soon enoughevotec1 will become famous soon enough
iTrader Score: 0 reviews
Default

When my injectors were bad i got fuel in the oil after shutdown from them leaking, and if i started it within 5-15 minutes itd crank a couple times b4 firing off
__________________
93 dx coupe jdm d15b nonvtec + si manual swap + PS -> manual rack swap + AC delete + Bosch WBO2 + MOATES & TunerView
evotec1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 05:17 PM. | Welcome to Forum, please register to access all of our features.