Torque/HP Drop on Dyno Graph - D-series.org

Go Back   D-series.org Motor Mayhem & Suspension Satisfaction Engine Management

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-05-2016, 09:43 AM   #1 (permalink)
n00b
 
iTrader: (0)
Join Date: Nov 2015
Posts: 23
Rep Power: 0 btruong968 is nobody
iTrader Score: 0 reviews
Default Torque/HP Drop on Dyno Graph

I recently did some pulls on virtual dyno, not really looking for numbers, just the graphs.

Anybody have any ideas on why I have such a steep fall in torque (and power) after about 5k? I thought the turbo was running out of breath so I turned the boost down but still have the same graph.

Setup:
D17A2 stock block, stock head
50 trim .42/.48 turbo
Log manifold
2.5" downpipe to 2.25" eBay exhaust
500cc injectors
Hondata Kpro running a street tuned basemap. 14* timing at 12 psi


12 psi:
https://drive.google.com/file/d/0B-F...ew?usp=sharing

11 psi:
https://drive.google.com/file/d/0B-F...ew?usp=sharing
btruong968 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-05-2016, 12:16 PM   #2 (permalink)
wise in the ways of the D
 
the hoove's Avatar
 
iTrader: (0)
Join Date: Jun 2010
Location: Tucson, AZ
Posts: 1,881
Rep Power: 20 the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!
the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!the hoove is the fucking MAN!!!!
iTrader Score: 0 reviews
Default

Quote:
Originally Posted by btruong968 View Post
I recently did some pulls on virtual dyno, not really looking for numbers, just the graphs.

Anybody have any ideas on why I have such a steep fall in torque (and power) after about 5k? I thought the turbo was running out of breath so I turned the boost down but still have the same graph.

Setup:
D17A2 stock block, stock head
50 trim .42/.48 turbo
Log manifold
2.5" downpipe to 2.25" eBay exhaust
500cc injectors
Hondata Kpro running a street tuned basemap. 14* timing at 12 psi


12 psi:
https://drive.google.com/file/d/0B-F...ew?usp=sharing

11 psi:
https://drive.google.com/file/d/0B-F...ew?usp=sharing
I'm gonna say the stock cam might be your issue. Also the log manifold possibly. for high revs, a ram horn would be better but you will see an increase in lag if you do that.
__________________
94 eg coupe (wrecked)
91 cb7 (sold)
07 crv (Sold to ex wife)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

92 teg ( new project)
Giving money and power to government is like giving whiskey and car keys to teenage boys with d series motors under the hood.

R.I.P Pat PRIMMER! You will be missed.

RIP Paul Walker.
R.I.P. NN4S.
RIP Cali-N00b.
the hoove is offline   Reply With Quote Quick reply to this message
Old 08-05-2016, 01:43 PM   #3 (permalink)
the artist formerly known as drexelstudent11
 
shoebox_civic's Avatar
 
iTrader: (14)
Join Date: Mar 2007
Location: Norristown, PA
Posts: 3,983
Rep Power: 28 shoebox_civic Still a JDM Star....shoebox_civic Still a JDM Star....
shoebox_civic Still a JDM Star....shoebox_civic Still a JDM Star....
iTrader Score: 14 reviews
Send a message via AIM to shoebox_civic
Default

stock cam for sure... also a lot of power for stock rods, they don't live super long at 225ftlbs
__________________
99 CRV
17 Q50 2.0T
07 350Z touring
90 Skyline GT-R - HKS Drager exhaust, RSR downpipe, metal wheel turbos
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
shoebox_civic is offline   Reply With Quote Quick reply to this message
 
Old 08-05-2016, 03:39 PM   #4 (permalink)
n00b
 
iTrader: (0)
Join Date: Nov 2015
Posts: 23
Rep Power: 0 btruong968 is nobody
iTrader Score: 0 reviews
Default

Quote:
Originally Posted by the hoove View Post
I'm gonna say the stock cam might be your issue. Also the log manifold possibly. for high revs, a ram horn would be better but you will see an increase in lag if you do that.
Quote:
Originally Posted by shoebox_civic View Post
stock cam for sure... also a lot of power for stock rods, they don't live super long at 225ftlbs
Awesome guys, thank you. I thought maybe it was the cam (and IM) but didn't want to cross off the exhaust as being too restrictive or turbo being too small.

A built motor should be going in the car soon, if not a K20. I got ARP head studs and rod bolts on the current one to help out a bit.
btruong968 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 02:36 PM. | Welcome to Forum, please register to access all of our features.