crx engine in wagon problems - D-series.org

Go Back   D-series.org Motor Mayhem & Suspension Satisfaction DOHC ZC

D-Series.org is the premier Honda All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-07-2012, 02:24 AM   #1 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default crx engine in wagon problems

Ok guys, i've finished wiring up my d16z5 swap in my previously twincarb shuttle. I've done this by putting a small part of a crx wire loom into a shuttle (from engine harness to ecu, that sensor under the dash and the main fuel relay and I've wired up all remaining wires accordingly).

What is working now:
Main relay
Starter
fuelpump

However, the ecu does not work

I've checked the following:
power: the ecu is getting power from the battery at all times ( at vbu)
Power from key in position 2: The ecu gets power from IGP1 and 2 when the key is in position 2
start contact: the ecu gets signal from the STS wire when you start the car
Ground: PG1 and 2 are grounded from an existing wire that runs behind the dashboard. The main relay is also grounded from this wire and it does not have any problems. I've tried grounding PG1 and 2 separately at a different point but that does not have a different effect.
I have also checked the ecu in another car and it works fine

The only thing I see is that when I put the key in position 1 I see a small bleep from the ecu led for a short moment and then nothing. When I put the key in position 2 the same happens. However there is no check engine light on on the dashboard.

What can I do and what can I check?
rbshuttle is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-07-2012, 02:48 AM   #2 (permalink)
wheres my money man!!
 
sleepingciv's Avatar
 
iTrader: (143)
Join Date: Oct 2008
Location: warsaw indiana
Posts: 11,333
Rep Power: 42 sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !
sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !
iTrader Score: 143 reviews
Send a message via AIM to sleepingciv Send a message via MSN to sleepingciv Send a message via Yahoo to sleepingciv
Default

The one flash in the ecu means its working.
Do you have spark?

Sent from my ZTE-Z990 using AutoGuide.Com Free App
__________________
PM me for
dpfi to mpfi obd0 or obd1 harnesses
also do tucked harnesses

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sleepingciv is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 04:08 AM   #3 (permalink)
Member
 
iTrader: (0)
Join Date: Sep 2011
Posts: 57
Rep Power: 0 Exodus191 is nobody
iTrader Score: 0 reviews
Default

Quote:
Originally Posted by rbshuttle View Post
Ok guys, i've finished wiring up my d16z5 swap in my previously twincarb shuttle. I've done this by putting a small part of a crx wire loom into a shuttle (from engine harness to ecu, that sensor under the dash and the main fuel relay and I've wired up all remaining wires accordingly).

What is working now:
Main relay
Starter
fuelpump

However, the ecu does not work

I've checked the following:
power: the ecu is getting power from the battery at all times ( at vbu)
Power from key in position 2: The ecu gets power from IGP1 and 2 when the key is in position 2
start contact: the ecu gets signal from the STS wire when you start the car
Ground: PG1 and 2 are grounded from an existing wire that runs behind the dashboard. The main relay is also grounded from this wire and it does not have any problems. I've tried grounding PG1 and 2 separately at a different point but that does not have a different effect.
I have also checked the ecu in another car and it works fine

The only thing I see is that when I put the key in position 1 I see a small bleep from the ecu led for a short moment and then nothing. When I put the key in position 2 the same happens. However there is no check engine light on on the dashboard.

What can I do and what can I check?
Hi, I'm interested in how you did this. I'm also in the process of a swap. Did you just use the Z6 engine harness, add in the main relay and run separate wires?
Which sensor under dash do u mean?
Sorry for going off topic and that i can't be of help but you are only person I found who did this. Can't find any info online.

Sent from my Galaxy Nexus using AutoGuide.Com Free App
Exodus191 is offline   Reply With Quote Quick reply to this message
 
Old 10-07-2012, 04:14 AM   #4 (permalink)
D-series PIMP
 
crxdonwon's Avatar
 
iTrader: (6)
Join Date: Jul 2010
Location: Ward, Arkansas
Posts: 1,054
Rep Power: 11 crxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to all
iTrader Score: 6 reviews
Default

Have you primed the fuel system well?

Set distributor in middle of adjustment, that'll get you close to correct timing.

Verify the distributor wiring.

Not sure what all wiring you had to change.
When you get into harnesses you have to check the wire from ecu plug to end sensor plug. Just because some things plug directly in doesn't mean the wires go to the same thing. When I put a 91 CRX SI engine and ecu harness in my 90 CRX DX I had to re-pin and swap plugs on some of the fuse box plugs and chassis harness. The best way to check wiring, if factory wire and plugs, is to make sure the wires are the same color and in the same position going in and out of the plugs. Get a volt meter.

You asked.
__________________
"Son... We don't cry unless we're bleedin' or broken!"
-DonWon

"Don't get too close to me, you'll get Horsepower on you!"
-DonWon
crxdonwon is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 04:15 AM   #5 (permalink)
D-series PIMP
 
crxdonwon's Avatar
 
iTrader: (6)
Join Date: Jul 2010
Location: Ward, Arkansas
Posts: 1,054
Rep Power: 11 crxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to all
iTrader Score: 6 reviews
Default

Also, what ecu?

You asked.
__________________
"Son... We don't cry unless we're bleedin' or broken!"
-DonWon

"Don't get too close to me, you'll get Horsepower on you!"
-DonWon
crxdonwon is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 04:43 AM   #6 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default

Quote:
Originally Posted by sleepingciv View Post
The one flash in the ecu means its working.
Do you have spark?

Sent from my ZTE-Z990 using AutoGuide.Com Free App
Its a really short flash, not the two second one from the cluster, that one does not light up

Quote:
Originally Posted by crxdonwon View Post
Have you primed the fuel system well?

Set distributor in middle of adjustment, that'll get you close to correct timing.

Verify the distributor wiring.

Not sure what all wiring you had to change.
When you get into harnesses you have to check the wire from ecu plug to end sensor plug. Just because some things plug directly in doesn't mean the wires go to the same thing. When I put a 91 CRX SI engine and ecu harness in my 90 CRX DX I had to re-pin and swap plugs on some of the fuse box plugs and chassis harness. The best way to check wiring, if factory wire and plugs, is to make sure the wires are the same color and in the same position going in and out of the plugs. Get a volt meter.

You asked.
I do not have a dpfi car, but a twincarb. The only wires that needed to be connected from the ecu was the wire for the check engine light and the vss output from the cluster. Other than that the only wires I had to hook up were related to the main fuel relay (which works), cluster, fuel pump and reverse lights.

I have cleaned all grounds in the engine bay (thermostat, gear box valve cover and where it connects to the chassis) : No effect
I have checked the main relay: Works fine in all positions
I have put the ecu on another ground which I know works from other things on my car: No effect

I am getting fuel, but no spark. I have checked spark by taking out a spark plug, put it back in the spark plug wire and hold it near a grounding point. When somebody started the car nothing happened


Quote:
Originally Posted by crxdonwon View Post
Also, what ecu?

You asked.
PM7
rbshuttle is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 05:20 AM   #7 (permalink)
D-series PIMP
 
crxdonwon's Avatar
 
iTrader: (6)
Join Date: Jul 2010
Location: Ward, Arkansas
Posts: 1,054
Rep Power: 11 crxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to all
iTrader Score: 6 reviews
Default

I didn't say YOU had a dpfi.
So... you are running a dual cab setup, or are you running mpfi?

You asked.
__________________
"Son... We don't cry unless we're bleedin' or broken!"
-DonWon

"Don't get too close to me, you'll get Horsepower on you!"
-DonWon
crxdonwon is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 06:03 AM   #8 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default

No just to clarify, I've had lots of people on diffent message boards pointing me towards dpfi-mpfi problems. But for me its carb-mpfi

Im gonna try to see if i get a signal from the check engine light wire, maybe the check engine light is broken in my new cluster
rbshuttle is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 06:32 AM   #9 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default

Is the check engine light a regular 12v signal? In that case I do not get a readout from the ecu when i put the key in position 2
rbshuttle is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 06:48 AM   #10 (permalink)
wheres my money man!!
 
sleepingciv's Avatar
 
iTrader: (143)
Join Date: Oct 2008
Location: warsaw indiana
Posts: 11,333
Rep Power: 42 sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !
sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !sleepingciv is on a level you can only DREAM about! ! !
iTrader Score: 143 reviews
Send a message via AIM to sleepingciv Send a message via MSN to sleepingciv Send a message via Yahoo to sleepingciv
Default

The red light in the ecu will flash fast once to show the ecu has power. Thats it. If it flashes more that means there are codes.

Do you have spark?
__________________
PM me for
dpfi to mpfi obd0 or obd1 harnesses
also do tucked harnesses

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
sleepingciv is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 07:32 AM   #11 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default

Ok, then the ecu has power. I have checked but I do not have spark
rbshuttle is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 07:40 AM   #12 (permalink)
D-series PIMP
 
crxdonwon's Avatar
 
iTrader: (6)
Join Date: Jul 2010
Location: Ward, Arkansas
Posts: 1,054
Rep Power: 11 crxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to all
iTrader Score: 6 reviews
Default

When you turn the key to run/on you should get a lamp test on the cluster. If you don't then you are missing a few more wires. Do you have a Chilton's, or some type of manual with the wiring diagrams for the year ecu have? There is an android app that has the ecu pinouts. Honda Database.

Verify that you have power to the distributor.
If you have a timing light, you can see if it is sending something. Hook it up and if it flashes then you are getting power through the spark plug wire, but not enough to jump the gap. Possible weak coil.

You asked.
__________________
"Son... We don't cry unless we're bleedin' or broken!"
-DonWon

"Don't get too close to me, you'll get Horsepower on you!"
-DonWon
crxdonwon is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 10:07 AM   #13 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default


This is the pinout I have, everything is connected
rbshuttle is offline   Reply With Quote Quick reply to this message
Old 10-07-2012, 10:31 AM   #14 (permalink)
D-series PIMP
 
crxdonwon's Avatar
 
iTrader: (6)
Join Date: Jul 2010
Location: Ward, Arkansas
Posts: 1,054
Rep Power: 11 crxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to allcrxdonwon is a name known to all
iTrader Score: 6 reviews
Default

What distributor are you using? Did you verify power to it?

You asked.
__________________
"Son... We don't cry unless we're bleedin' or broken!"
-DonWon

"Don't get too close to me, you'll get Horsepower on you!"
-DonWon
crxdonwon is offline   Reply With Quote Quick reply to this message
Old 10-08-2012, 06:52 AM   #15 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default

I'll go and check that one. which wires are the power and signal wires on the distributor plugs?
rbshuttle is offline   Reply With Quote Quick reply to this message
Old 10-17-2012, 05:41 AM   #16 (permalink)
n00b
 
iTrader: (0)
Join Date: Sep 2012
Posts: 13
Rep Power: 0 rbshuttle is nobody
iTrader Score: 0 reviews
Default

Ok, im losing interest in the car
Anyways, the thick black/yellow wire has 12v coming through it when the key is in position 2. Also the ignition unit works fine on my friends car
rbshuttle is offline   Reply With Quote Quick reply to this message
Old 10-18-2012, 12:27 PM   #17 (permalink)
D-series lover
 
Redtapemassacre's Avatar
 
iTrader: (7)
Join Date: Aug 2006
Location: New York
Posts: 247
Rep Power: 13 Redtapemassacre is starting to learn the ropesRedtapemassacre is starting to learn the ropesRedtapemassacre is starting to learn the ropesRedtapemassacre is starting to learn the ropesRedtapemassacre is starting to learn the ropesRedtapemassacre is starting to learn the ropes
iTrader Score: 7 reviews
Default

When you swaped motors did you swap the entire crx engine harness into the shuttle?
Someone correct me if I'm wrong but would you need to run a resistor box to run the obd0 injectors?
Sorry, for frustration there not much info out there on this swap.
If it were me I either swap the entire dash harness and engine harness form the crx into the shuttle. Or used the crx engine harness and depin than repin the ecu plugs so they match the diagram you posted.
__________________
awebb:Magical spinning Doritos do not belong in cars...
Redtapemassacre is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the D-series.org forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Security Question
*Required, this field is not shown to others: While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what kind of animal is mentioned in the sentence above.
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


iconAll times are GMT -8. The time now is 05:21 AM. | Welcome to Forum, please register to access all of our features.